{"answers":{"affected":"2 open source packages ship an affected version, including survey-creator. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28635 exists.","fix":"Upgrade survey-creator to 1.9.133 or later.","what":"CVE-2024-28635 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-28635 and fix it if it is affected.\n\nWhat it is: CVE-2024-28635 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28635 exists.\n\nAffected packages and fixed versions:\n- survey-creator (npm): affected all versions; fixed in 1.9.133\n- survey-creator (npm): affected all versions; fixed in 1.9.133\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28635/ (Markdown: https://insights.sbomify.com/CVE-2024-28635/index.md)","id":"CVE-2024-28635","markdown":"https://insights.sbomify.com/CVE-2024-28635/index.md","name":"CVE-2024-28635","record":{"aliases":["GHSA-xgj4-2hrf-j4xg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"SurveyJS Survey Creator","requires_auth":"none","summary":"Attackers can execute arbitrary code and steal sensitive information via XSS in the title parameter of SurveyJS Survey Creator.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"survey-creator","vendor":"devsoftbaltic"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site scripting in Survey Creator","id":"CVE-2024-28635","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2024-28639"},"packages":[{"ecosystem":"npm","fixed":["1.9.133"],"introduced":["0"],"last_affected":[],"package":"survey-creator","purl":null,"source":"GHSA-xgj4-2hrf-j4xg"},{"ecosystem":"npm","fixed":["1.9.133"],"introduced":["0"],"last_affected":[],"package":"survey-creator","purl":"pkg:npm/survey-creator","source":"GHSA-xgj4-2hrf-j4xg"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2024-28627"},"products":["n/a"],"published":"2024-03-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code and steal sensitive information via XSS in the title parameter of SurveyJS Survey Creator.","url":"https://insights.sbomify.com/CVE-2024-28635/"}