# CVE-2024-28635: Cross-site scripting in Survey Creator

> Attackers can execute arbitrary code and steal sensitive information via XSS in the title parameter of SurveyJS Survey Creator.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-xgj4-2hrf-j4xg

## What is CVE-2024-28635?

CVE-2024-28635 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-28635?

2 open source packages ship an affected version, including survey-creator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `survey-creator` | npm | All versions | 1.9.133 |
| `survey-creator` | npm | All versions | 1.9.133 |

Products: Devsoftbaltic Survey-Creator.

## How do I fix CVE-2024-28635?

Upgrade survey-creator to 1.9.133 or later.

## Is CVE-2024-28635 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28635 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28635 and fix it if it is affected.

What it is: CVE-2024-28635 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28635 exists.

Affected packages and fixed versions:
- survey-creator (npm): affected all versions; fixed in 1.9.133
- survey-creator (npm): affected all versions; fixed in 1.9.133

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28635/ (Markdown: https://insights.sbomify.com/CVE-2024-28635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28635
- OSV: https://osv.dev/vulnerability/CVE-2024-28635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28635/
Summaries are generated and may contain mistakes; the official description above is the record.
