# CVE-2024-28698: CLSA Directory Traversal vulnerability

> A remote attacker can execute arbitrary code via a crafted script in the MobileFormatter component of the CSLA .NET library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9xhh-3m78-gvgj

## What is CVE-2024-28698?

CVE-2024-28698 is a critical path traversal vulnerability in n/a, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory Traversal vulnerability in Marimer LLC CSLA .Net before 8.0 allows a remote attacker to execute arbitrary code via a crafted script to the MobileFormatter component.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-28698?

6 open source packages ship an affected version, including Csla.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Csla` | NuGet | All versions | 5.5.4 |
| `Csla` | NuGet | All versions | 5.5.4 |
| `Csla` | NuGet | From 6.0.0 | 8.0.0 |
| `Csla` | NuGet | From 6.0.0 | 8.0.0 |
| `Csla` | NuGet | From 7.0.0 | 8.0.0 |
| `Csla` | NuGet | From 7.0.0 | 8.0.0 |

## How do I fix CVE-2024-28698?

Upgrade Csla to a fixed version for your release line: 5.5.4 or 8.0.0.

## Is CVE-2024-28698 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28698 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28698 and fix it if it is affected.

What it is: CVE-2024-28698 is a critical path traversal vulnerability in n/a, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28698 exists.

Affected packages and fixed versions:
- Csla (NuGet): affected all versions; fixed in 5.5.4
- Csla (NuGet): affected all versions; fixed in 5.5.4
- Csla (NuGet): affected from 6.0.0; fixed in 8.0.0
- Csla (NuGet): affected from 6.0.0; fixed in 8.0.0
- Csla (NuGet): affected from 7.0.0; fixed in 8.0.0
- Csla (NuGet): affected from 7.0.0; fixed in 8.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28698/ (Markdown: https://insights.sbomify.com/CVE-2024-28698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28698
- OSV: https://osv.dev/vulnerability/CVE-2024-28698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28698/
Summaries are generated and may contain mistakes; the official description above is the record.
