# CVE-2024-28709: LimeSurvey Cross Site Scripting vulnerability

> Remote attackers can execute arbitrary code via crafted scripts in LimeSurvey title and comment fields, requiring an upgrade to secure the application.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Oct 2024
- **Updated:** 5 Jul 2026
- **Also known as:** BIT-limesurvey-2024-28709, GHSA-c7xm-rwqj-pgcj

## What is CVE-2024-28709?

CVE-2024-28709 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerability in LimeSurvey before 6.5.12+240611 allows a remote attacker to execute arbitrary code via a crafted script to the title and comment fields.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-28709?

3 open source packages ship an affected version, including limesurvey/limesurvey and limesurvey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limesurvey/limesurvey` | Packagist | All versions | 6.5.12 |
| `limesurvey/limesurvey` | Packagist | All versions | 6.5.12 |
| `limesurvey` | Bitnami | All versions | 6.5.12 |

Products: Limesurvey Limesurvey.

## How do I fix CVE-2024-28709?

Upgrade limesurvey/limesurvey to 6.5.12 or later.

## Is CVE-2024-28709 being exploited?

There is no known exploitation of CVE-2024-28709 in the wild and no public exploit code.

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2022-48008](https://insights.sbomify.com/CVE-2022-48008/): File upload in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28709 and fix it if it is affected.

What it is: CVE-2024-28709 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 7 Oct 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-28709 in the wild and no public exploit code.

Affected packages and fixed versions:
- limesurvey/limesurvey (Packagist): affected all versions; fixed in 6.5.12
- limesurvey/limesurvey (Packagist): affected all versions; fixed in 6.5.12
- limesurvey (Bitnami): affected all versions; fixed in 6.5.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28709/ (Markdown: https://insights.sbomify.com/CVE-2024-28709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28709
- OSV: https://osv.dev/vulnerability/CVE-2024-28709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28709/
Summaries are generated and may contain mistakes; the official description above is the record.
