{"answers":{"affected":"3 open source packages ship an affected version, including storlets.","exploited":"There is no known exploitation of CVE-2024-28717 in the wild and no public exploit code.","fix":"Upgrade storlets to 13.0.0.0rc1 or later.","what":"CVE-2024-28717 is a medium-severity denial of service vulnerability in n/a, published on 22 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28717 and fix it if it is affected.\n\nWhat it is: CVE-2024-28717 is a medium-severity denial of service vulnerability in n/a, published on 22 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28717 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- storlets (PyPI): affected all versions; fixed in 13.0.0.0rc1\n- storlets (PyPI): affected all versions; fixed in 13.0.0.0rc1\n- storlets (PyPI): affected all versions; fixed in 13.0.0.0rc1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28717/ (Markdown: https://insights.sbomify.com/CVE-2024-28717/index.md)","id":"CVE-2024-28717","markdown":"https://insights.sbomify.com/CVE-2024-28717/index.md","name":"CVE-2024-28717","record":{"aliases":["GHSA-rfm2-f94j-qhjp","PYSEC-2026-1945"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenStack Storlets","requires_auth":"high_privilege","summary":"A remote attacker can cause a denial of service in OpenStack Storlets via the gateway component, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"An issue in OpenStack Storlets yoga-eom allows a remote attacker to execute arbitrary code via the gateway.py component.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenStack Storlets arbitrary code execution vulnerability","id":"CVE-2024-28717","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"OpenStack magnum vulnerable to time-of-check to time-of-use (TOCTOU) attack","id":"CVE-2024-28718"},"packages":[{"ecosystem":"PyPI","fixed":["13.0.0.0rc1"],"introduced":["0"],"last_affected":[],"package":"storlets","purl":null,"source":"GHSA-rfm2-f94j-qhjp"},{"ecosystem":"PyPI","fixed":["13.0.0.0rc1"],"introduced":["0"],"last_affected":[],"package":"storlets","purl":"pkg:pypi/storlets","source":"GHSA-rfm2-f94j-qhjp"},{"ecosystem":"PyPI","fixed":["13.0.0.0rc1"],"introduced":["0"],"last_affected":[],"package":"storlets","purl":"pkg:pypi/storlets","source":"PYSEC-2026-1945"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2024-28716"},"products":["n/a"],"published":"2024-04-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"A remote attacker can cause a denial of service in OpenStack Storlets via the gateway component, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2024-28717/"}