# CVE-2024-28717: OpenStack Storlets arbitrary code execution vulnerability

> A remote attacker can cause a denial of service in OpenStack Storlets via the gateway component, requiring an upgrade to mitigate.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-rfm2-f94j-qhjp, PYSEC-2026-1945

## What is CVE-2024-28717?

CVE-2024-28717 is a medium-severity denial of service vulnerability in n/a, published on 22 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue in OpenStack Storlets yoga-eom allows a remote attacker to execute arbitrary code via the gateway.py component.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-28717?

3 open source packages ship an affected version, including storlets.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `storlets` | PyPI | All versions | 13.0.0.0rc1 |
| `storlets` | PyPI | All versions | 13.0.0.0rc1 |
| `storlets` | PyPI | All versions | 13.0.0.0rc1 |

## How do I fix CVE-2024-28717?

Upgrade storlets to 13.0.0.0rc1 or later.

## Is CVE-2024-28717 being exploited?

There is no known exploitation of CVE-2024-28717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28717 and fix it if it is affected.

What it is: CVE-2024-28717 is a medium-severity denial of service vulnerability in n/a, published on 22 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28717 in the wild and no public exploit code.

Affected packages and fixed versions:
- storlets (PyPI): affected all versions; fixed in 13.0.0.0rc1
- storlets (PyPI): affected all versions; fixed in 13.0.0.0rc1
- storlets (PyPI): affected all versions; fixed in 13.0.0.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28717/ (Markdown: https://insights.sbomify.com/CVE-2024-28717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28717
- OSV: https://osv.dev/vulnerability/CVE-2024-28717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28717/
Summaries are generated and may contain mistakes; the official description above is the record.
