CVE-2024-2874 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An attacker with runner registration permissions can cause denial of service by crafting a runner description that disrupts GitLab web resource loading.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-2874?

CVE-2024-2874 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 23 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 16.10.6, version 16.11 before 16.11.3, and 17.0 before 17.0.1. A runner registered with a crafted description has the potential to disrupt the loading of targeted GitLab web resources.

Weakness: CWE-770

Which versions are affected by CVE-2024-2874?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions16.10.6, 16.11.3, 17.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-2874?

Upgrade gitlab to a fixed version for your release line: 16.10.6, 16.11.3 or 17.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-2874 being exploited?

There is no known exploitation of CVE-2024-2874 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-2874, GHSA-r6p6-7q5h-jc4x, UBUNTU-CVE-2024-2874.

Is CVE-2024-2874 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free