CVE-2024-28746 Apache Airflow: Ignored Airflow Permissions

High 8.1 Published Updated

Authenticated users with limited permissions can access unauthorized resources like variables and connections via the UI.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-28746?

CVE-2024-28746 is a high-severity missing authorization vulnerability in Apache Airflow, published on 14 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. 

Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Weakness: CWE-281

Which versions are affected by CVE-2024-28746?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIFrom 2.8.02.8.3rc1
apache-airflow PyPIFrom 2.8.02.8.3rc1
apache-airflow PyPIFrom 2.8.02.8.3rc1
airflow BitnamiFrom 2.8.02.8.3

Products include Apache Airflow.

How do I fix CVE-2024-28746?

Upgrade apache-airflow to 2.8.3rc1 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-28746 being exploited?

There is no known exploitation of CVE-2024-28746 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2024-28746, GHSA-h574-6646-vfxx, PYSEC-2024-46.

Is CVE-2024-28746 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free