{"answers":{"affected":"2 open source packages ship an affected version, including billz/raspap-webgui. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28754 in the wild and no public exploit code.","fix":"Upgrade billz/raspap-webgui to 3.1.0 or later.","what":"CVE-2024-28754 is a high-severity denial of service vulnerability in n/a, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28754 and fix it if it is affected.\n\nWhat it is: CVE-2024-28754 is a high-severity denial of service vulnerability in n/a, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28754 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.1.0\n- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28754/ (Markdown: https://insights.sbomify.com/CVE-2024-28754/index.md)","id":"CVE-2024-28754","markdown":"https://insights.sbomify.com/CVE-2024-28754/index.md","name":"CVE-2024-28754","record":{"aliases":["GHSA-vc9f-mgxr-h32r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RaspAP web interface","requires_auth":"none","summary":"Remote attackers can cause persistent denial of service by sending crafted requests to the RaspAP web interface.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"raspap","vendor":"raspap"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"raspap-webgui vulnerable to denial of service","id":"CVE-2024-28754","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2024-28755"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"billz/raspap-webgui","purl":null,"source":"GHSA-vc9f-mgxr-h32r"},{"ecosystem":"Packagist","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"billz/raspap-webgui","purl":"pkg:composer/billz/raspap-webgui","source":"GHSA-vc9f-mgxr-h32r"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2024-28753"},"products":["n/a"],"published":"2024-03-08","related":[{"cvss_score":9.8,"headline":"RaspAP Command Injection vulnerability","id":"CVE-2022-39986","kev_date_added":null,"published":"2023-08-01"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2021-33357","kev_date_added":null,"published":"2021-06-09"},{"cvss_score":8.8,"headline":"RaspAP Command Injection vulnerability","id":"CVE-2022-39987","kev_date_added":null,"published":"2023-08-01"},{"cvss_score":8.8,"headline":"RaspAP raspap-webgui Command Injection vulnerability","id":"CVE-2023-30260","kev_date_added":null,"published":"2023-06-23"},{"cvss_score":8.8,"headline":"Command Injection in RaspAP 2.6.6","id":"CVE-2021-38556","kev_date_added":null,"published":"2021-08-24"},{"cvss_score":8.8,"headline":"raspap-webgui in RaspAP 2.6.6 allows attackers to execute commands as root because of the insecure sudoers permissions.","id":"CVE-2021-38557","kev_date_added":null,"published":"2021-08-24"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2021-33356","kev_date_added":null,"published":"2021-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-01","vendors":["n/a"]},"summary":"Remote attackers can cause persistent denial of service by sending crafted requests to the RaspAP web interface.","url":"https://insights.sbomify.com/CVE-2024-28754/"}