# CVE-2024-28754: raspap-webgui vulnerable to denial of service

> Remote attackers can cause persistent denial of service by sending crafted requests to the RaspAP web interface.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2024
- **Updated:** 1 Nov 2024
- **Also known as:** GHSA-vc9f-mgxr-h32r

## What is CVE-2024-28754?

CVE-2024-28754 is a high-severity denial of service vulnerability in n/a, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

## Which versions are affected by CVE-2024-28754?

2 open source packages ship an affected version, including billz/raspap-webgui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `billz/raspap-webgui` | Packagist | All versions | 3.1.0 |
| `billz/raspap-webgui` | Packagist | All versions | 3.1.0 |

Products: Raspap Raspap.

## How do I fix CVE-2024-28754?

Upgrade billz/raspap-webgui to 3.1.0 or later.

## Is CVE-2024-28754 being exploited?

There is no known exploitation of CVE-2024-28754 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-39986](https://insights.sbomify.com/CVE-2022-39986/): RaspAP Command Injection vulnerability (critical 9.8)
- [CVE-2021-33357](https://insights.sbomify.com/CVE-2021-33357/): Command injection in n/a (critical 9.8)
- [CVE-2022-39987](https://insights.sbomify.com/CVE-2022-39987/): RaspAP Command Injection vulnerability (high 8.8)
- [CVE-2023-30260](https://insights.sbomify.com/CVE-2023-30260/): RaspAP raspap-webgui Command Injection vulnerability (high 8.8)
- [CVE-2021-38556](https://insights.sbomify.com/CVE-2021-38556/): Command Injection in RaspAP 2.6.6 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28754 and fix it if it is affected.

What it is: CVE-2024-28754 is a high-severity denial of service vulnerability in n/a, published on 8 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28754 in the wild and no public exploit code.

Affected packages and fixed versions:
- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.1.0
- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28754/ (Markdown: https://insights.sbomify.com/CVE-2024-28754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28754
- OSV: https://osv.dev/vulnerability/CVE-2024-28754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28754/
Summaries are generated and may contain mistakes; the official description above is the record.
