CVE-2024-2880 Improper Access Control in GitLab
A user with specific custom role permissions can improperly ban group members, requiring an upgrade to GitLab to fix.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-2880?
CVE-2024-2880 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 11 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.5 prior to 16.11.6, starting from 17.0 prior to 17.0.4, and starting from 17.1 prior to 17.1.2 in which a user with `admin_group_member` custom role permission could ban group members.
Weakness: CWE-284
Which versions are affected by CVE-2024-2880?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.5.0 | 16.11.6, 17.0.4, 17.1.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-2880?
Upgrade gitlab to a fixed version for your release line: 16.11.6, 17.0.4 or 17.1.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-2880 being exploited?
There is no known exploitation of CVE-2024-2880 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-2880, GHSA-xxw9-chfj-mp3c, UBUNTU-CVE-2024-2880.