# CVE-2024-28847: SpEL Injection in `PUT /api/v1/events/subscriptions` in OpenMetadata

> An attacker can achieve remote code execution by injecting SpEL expressions into event subscription updates before authorization checks occur.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 27 Aug 2024
- **Also known as:** GHSA-8p5r-6mvv-2435

## What is CVE-2024-28847?

CVE-2024-28847 is a high-severity code injection vulnerability in open-metadata OpenMetadata, published on 15 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenMetadata is a unified platform for discovery, observability, and governance powered by a central metadata repository, in-depth lineage, and seamless team collaboration. Similarly to the GHSL-2023-250 issue, `AlertUtil::validateExpression` is also called from `EventSubscriptionRepository.prepare()`, which can lead to Remote Code Execution. `prepare()` is called from `EntityRepository.prepareInternal()` which, in turn, gets called from `EntityResource.createOrUpdate()`. Note that, even though there is an authorization check (`authorizer.authorize()`), it gets called after `prepareInternal()` gets called and, therefore, after the SpEL expression has been evaluated. In order to reach this method, an attacker can send a PUT request to `/api/v1/events/subscriptions` which gets handled by `EventSubscriptionResource.createOrUpdateEventSubscription()`. This vulnerability was discovered with the help of CodeQL's Expression language injection (Spring) query. This issue may lead to Remote Code Execution and has been addressed in version 1.2.4. Users are advised to upgrade. There are no known workarounds for this vulnerability. This issue is also tracked as `GHSL-2023-251`.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-28847?

2 open source packages ship an affected version, including org.open-metadata:openmetadata-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.open-metadata:openmetadata-service` | Maven | All versions | 1.2.4 |
| `org.open-metadata:openmetadata-service` | Maven | All versions | 1.2.4 |

Products: Open-Metadata Openmetadata.

## How do I fix CVE-2024-28847?

Upgrade org.open-metadata:openmetadata-service to 1.2.4 or later.

## Is CVE-2024-28847 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28847 exists.

## Other vulnerabilities in open-metadata OpenMetadata

- [CVE-2024-28255](https://insights.sbomify.com/CVE-2024-28255/): Authentication Bypass in OpenMetadata (critical 9.8)
- [CVE-2024-28253](https://insights.sbomify.com/CVE-2024-28253/): SpEL Injection in `PUT /api/v1/policies` in OpenMetadata (critical 9.4)
- [CVE-2024-28254](https://insights.sbomify.com/CVE-2024-28254/): SpEL Injection in `GET /api/v1/events/subscriptions/validation/condition/<expr>` in OpenMetadata (high 8.8)
- [CVE-2024-28848](https://insights.sbomify.com/CVE-2024-28848/): SpEL Injection in `GET /api/v1/policies/validation/condition/<expr>` in OpenMetadata (high 8.8)
- [CVE-2026-22244](https://insights.sbomify.com/CVE-2026-22244/): OpenMetadata Server-Side Template Injection (SSTI) in FreeMarker email templates that leads to RCE (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28847 and fix it if it is affected.

What it is: CVE-2024-28847 is a high-severity code injection vulnerability in open-metadata OpenMetadata, published on 15 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28847 exists.

Affected packages and fixed versions:
- org.open-metadata:openmetadata-service (Maven): affected all versions; fixed in 1.2.4
- org.open-metadata:openmetadata-service (Maven): affected all versions; fixed in 1.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28847/ (Markdown: https://insights.sbomify.com/CVE-2024-28847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28847
- OSV: https://osv.dev/vulnerability/CVE-2024-28847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28847/
Summaries are generated and may contain mistakes; the official description above is the record.
