{"answers":{"affected":"2 open source packages ship an affected version, including follow-redirects. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28849 exists.","fix":"Upgrade follow-redirects to 1.15.6 or later.","what":"CVE-2024-28849 is a medium-severity vulnerability in follow-redirects, published on 14 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28849 and fix it if it is affected.\n\nWhat it is: CVE-2024-28849 is a medium-severity vulnerability in follow-redirects, published on 14 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28849 exists.\n\nAffected packages and fixed versions:\n- follow-redirects (npm): affected all versions; fixed in 1.15.6\n- follow-redirects (npm): affected all versions; fixed in 1.15.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28849/ (Markdown: https://insights.sbomify.com/CVE-2024-28849/index.md)","id":"CVE-2024-28849","markdown":"https://insights.sbomify.com/CVE-2024-28849/index.md","name":"CVE-2024-28849","record":{"aliases":["AZL-36895","AZL-43861","AZL-44493","CLSA-2026-1776818198","DEBIAN-CVE-2024-28849","GHSA-cxjh-pqwp-8mfp","UBUNTU-CVE-2024-28849"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP library","requires_auth":"low_privilege","summary":"The follow-redirects library leaks Proxy-Authorization credentials to unintended hosts during redirects, requiring an upgrade to prevent credential exposure.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"follow-redirects","vendor":"follow-redirects_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"follow-redirects is an open source, drop-in replacement for Node's `http` and `https` modules that automatically follows redirects. In affected versions follow-redirects only clears authorization header during cross-domain redirect, but keep the proxy-authentication header which contains credentials too. This vulnerability may lead to credentials leak, but has been addressed in version 1.15.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Proxy-Authorization header kept across hosts in follow-redirects","id":"CVE-2024-28849","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":6,"next":{"headline":"WP Crontrol possible RCE when combined with a pre-condition","id":"CVE-2024-28850"},"packages":[{"ecosystem":"npm","fixed":["1.15.6"],"introduced":["0"],"last_affected":[],"package":"follow-redirects","purl":null,"source":"GHSA-cxjh-pqwp-8mfp"},{"ecosystem":"npm","fixed":["1.15.6"],"introduced":["0"],"last_affected":[],"package":"follow-redirects","purl":"pkg:npm/follow-redirects","source":"GHSA-cxjh-pqwp-8mfp"}],"prev":{"headline":"SpEL Injection in `GET /api/v1/policies/validation/condition/\u003cexpr\u003e` in OpenMetadata","id":"CVE-2024-28848"},"products":["follow-redirects"],"published":"2024-03-14","related":[{"cvss_score":8,"headline":"Exposure of Private Personal Information to an Unauthorized Actor in follow-redirects/follow-redirects","id":"CVE-2022-0155","kev_date_added":null,"published":"2022-01-10"},{"cvss_score":6.9,"headline":"follow-redirects: Custom Authentication Headers Leaked to Cross-Domain Redirect Targets","id":"CVE-2026-40895","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":2.6,"headline":"Improper Removal of Sensitive Information Before Storage or Transfer in follow-redirects/follow-redirects","id":"CVE-2022-0536","kev_date_added":null,"published":"2022-02-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["follow-redirects"]},"summary":"The follow-redirects library leaks Proxy-Authorization credentials to unintended hosts during redirects, requiring an upgrade to prevent credential exposure.","url":"https://insights.sbomify.com/CVE-2024-28849/"}