{"answers":{"affected":"2 open source packages ship an affected version, including johnbillion/wp-crontrol. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28850 in the wild and no public exploit code.","fix":"Upgrade johnbillion/wp-crontrol to 1.16.2 or later.","what":"CVE-2024-28850 is a high-severity code injection vulnerability in johnbillion wp-crontrol, published on 25 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28850 and fix it if it is affected.\n\nWhat it is: CVE-2024-28850 is a high-severity code injection vulnerability in johnbillion wp-crontrol, published on 25 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28850 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- johnbillion/wp-crontrol (Packagist): affected all versions; fixed in 1.16.2\n- johnbillion/wp-crontrol (Packagist): affected all versions; fixed in 1.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28850/ (Markdown: https://insights.sbomify.com/CVE-2024-28850/index.md)","id":"CVE-2024-28850","markdown":"https://insights.sbomify.com/CVE-2024-28850/index.md","name":"CVE-2024-28850","record":{"aliases":["GHSA-9xvf-cjvf-ff5q"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"WordPress plugin","requires_auth":"none","summary":"Administrators can execute arbitrary PHP code via WP Crontrol if combined with other vulnerabilities like SQL injection or database compromise.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wp_crontrol","vendor":"johnbillion"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-494","name":"Download of Code Without Integrity Check"}],"description":"WP Crontrol controls the cron events on WordPress websites.  WP Crontrol includes a feature that allows administrative users to create events in the WP-Cron system that store and execute PHP code subject to the restrictive security permissions documented here. While there is no known vulnerability in this feature on its own, there exists potential for this feature to be vulnerable to RCE if it were specifically targeted via vulnerability chaining that exploited a separate SQLi (or similar) vulnerability. This is exploitable on a site if one of the below preconditions are met, the site is vulnerable to a writeable SQLi vulnerability in any plugin, theme, or WordPress core, the site's database is compromised at the hosting level, the site is vulnerable to a method of updating arbitrary options in the wp_options table, or the site is vulnerable to a method of triggering an arbitrary action, filter, or function with control of the parameters.  As a hardening measure, WP Crontrol version 1.16.2 ships with a new feature that prevents tampering of the code stored in a PHP cron event.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WP Crontrol possible RCE when combined with a pre-condition","id":"CVE-2024-28850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Elevation of privilege in Snowflake Hive MetaStore Connector Helper script","id":"CVE-2024-28851"},"packages":[{"ecosystem":"Packagist","fixed":["1.16.2"],"introduced":["0"],"last_affected":[],"package":"johnbillion/wp-crontrol","purl":null,"source":"GHSA-9xvf-cjvf-ff5q"},{"ecosystem":"Packagist","fixed":["1.16.2"],"introduced":["0"],"last_affected":[],"package":"johnbillion/wp-crontrol","purl":"pkg:composer/johnbillion/wp-crontrol","source":"GHSA-9xvf-cjvf-ff5q"}],"prev":{"headline":"Proxy-Authorization header kept across hosts in follow-redirects","id":"CVE-2024-28849"},"products":["wp-crontrol"],"published":"2024-03-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["johnbillion"]},"summary":"Administrators can execute arbitrary PHP code via WP Crontrol if combined with other vulnerabilities like SQL injection or database compromise.","url":"https://insights.sbomify.com/CVE-2024-28850/"}