# CVE-2024-28853: Ampache Stored XSS


- **Severity:** Low 3.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Mar 2024
- **Updated:** 29 Aug 2024
- **Also known as:** GHSA-prw2-7cr3-5mx8, UBUNTU-CVE-2024-28853

## What is CVE-2024-28853?

CVE-2024-28853 is a low-severity vulnerability in ampache, published on 27 Mar 2024. 

### Official description

Ampache is a web based audio/video streaming application and file manager. Stored Cross Site Scripting (XSS) vulnerability in ampache before v6.3.1 allows a remote attacker to execute code via a crafted payload to serval parameters in the post request of /preferences.php?action=admin_update_preferences. This vulnerability is fixed in 6.3.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-28853?

It affects 1 product.


Products: Ampache Ampache.

## How do I fix CVE-2024-28853?

No fix has been published for CVE-2024-28853 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-28853 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28853 exists.

## Other vulnerabilities in ampache

- [CVE-2023-0606](https://insights.sbomify.com/CVE-2023-0606/): Cross-site Scripting (XSS) - Reflected in ampache/ampache (critical 9.3)
- [CVE-2021-21399](https://insights.sbomify.com/CVE-2021-21399/): Unauthenticated SubSonic backend access in Ampache (critical 9.1)
- [CVE-2019-12385](https://insights.sbomify.com/CVE-2019-12385/): SQL injection in n/a (high 8.8)
- [CVE-2017-18375](https://insights.sbomify.com/CVE-2017-18375/): Deserialization in n/a (high 8.8)
- [CVE-2020-15153](https://insights.sbomify.com/CVE-2020-15153/): Unauthenticated SQL injection in Ampache (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28853 and fix it if it is affected.

What it is: CVE-2024-28853 is a low-severity vulnerability in ampache, published on 27 Mar 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28853 exists.

Affected product: ampache. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28853/ (Markdown: https://insights.sbomify.com/CVE-2024-28853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28853
- OSV: https://osv.dev/vulnerability/CVE-2024-28853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28853/
Summaries are generated and may contain mistakes; the official description above is the record.
