{"answers":{"affected":"3 open source packages ship an affected version, including tls-listener. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28854 exists.","fix":"Upgrade tls-listener to 0.10.0 or later.","what":"CVE-2024-28854 is a high-severity denial of service vulnerability in tmccombs tls-listener, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28854 and fix it if it is affected.\n\nWhat it is: CVE-2024-28854 is a high-severity denial of service vulnerability in tmccombs tls-listener, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28854 exists.\n\nAffected packages and fixed versions:\n- tls-listener (crates.io): affected all versions; fixed in 0.10.0\n- tls-listener (crates.io): affected all versions; fixed in 0.10.0\n- tls-listener (crates.io): affected from 0.0.0-0; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28854/ (Markdown: https://insights.sbomify.com/CVE-2024-28854/index.md)","id":"CVE-2024-28854","markdown":"https://insights.sbomify.com/CVE-2024-28854/index.md","name":"CVE-2024-28854","record":{"aliases":["GHSA-2qph-qpvm-2qf7","RUSTSEC-2024-0341"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust TLS listener library","requires_auth":"none","summary":"A malicious user can cause a denial of service in services using the tls-listener library by opening many TCP connections with zero bytes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tls-listener","vendor":"tmccombs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"tls-listener is a rust lang wrapper around a connection listener to support TLS. With the default configuration of tls-listener, a malicious user can open 6.4 `TcpStream`s a second, sending 0 bytes, and can trigger a DoS. The default configuration options make any public service using `TlsListener::new()` vulnerable to a slow-loris DoS attack. This impacts any publicly accessible service using the default configuration of tls-listener in versions prior to 0.10.0. Users are advised to upgrade. Users unable to upgrade may mitigate this by passing a large value, such as `usize::MAX` as the parameter to `Builder::max_handshakes`.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Slow loris vulnerability with default configuration in tls-listener","id":"CVE-2024-28854","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"ZITADEL vulnerable to improper HTML sanitization","id":"CVE-2024-28855"},"packages":[{"ecosystem":"crates.io","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"tls-listener","purl":null,"source":"GHSA-2qph-qpvm-2qf7"},{"ecosystem":"crates.io","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"tls-listener","purl":"pkg:cargo/tls-listener","source":"GHSA-2qph-qpvm-2qf7"},{"ecosystem":"crates.io","fixed":["0.10.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"tls-listener","purl":"pkg:cargo/tls-listener","source":"RUSTSEC-2024-0341"}],"prev":{"headline":"Ampache Stored XSS","id":"CVE-2024-28853"},"products":["tls-listener"],"published":"2024-03-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["tmccombs"]},"summary":"A malicious user can cause a denial of service in services using the tls-listener library by opening many TCP connections with zero bytes.","url":"https://insights.sbomify.com/CVE-2024-28854/"}