# CVE-2024-28854: Slow loris vulnerability with default configuration in tls-listener

> A malicious user can cause a denial of service in services using the tls-listener library by opening many TCP connections with zero bytes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2qph-qpvm-2qf7, RUSTSEC-2024-0341

## What is CVE-2024-28854?

CVE-2024-28854 is a high-severity denial of service vulnerability in tmccombs tls-listener, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

tls-listener is a rust lang wrapper around a connection listener to support TLS. With the default configuration of tls-listener, a malicious user can open 6.4 `TcpStream`s a second, sending 0 bytes, and can trigger a DoS. The default configuration options make any public service using `TlsListener::new()` vulnerable to a slow-loris DoS attack. This impacts any publicly accessible service using the default configuration of tls-listener in versions prior to 0.10.0. Users are advised to upgrade. Users unable to upgrade may mitigate this by passing a large value, such as `usize::MAX` as the parameter to `Builder::max_handshakes`.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-28854?

3 open source packages ship an affected version, including tls-listener. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tls-listener` | crates.io | All versions | 0.10.0 |
| `tls-listener` | crates.io | All versions | 0.10.0 |
| `tls-listener` | crates.io | From 0.0.0-0 | 0.10.0 |

Products: Tmccombs Tls-Listener.

## How do I fix CVE-2024-28854?

Upgrade tls-listener to 0.10.0 or later.

## Is CVE-2024-28854 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28854 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28854 and fix it if it is affected.

What it is: CVE-2024-28854 is a high-severity denial of service vulnerability in tmccombs tls-listener, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28854 exists.

Affected packages and fixed versions:
- tls-listener (crates.io): affected all versions; fixed in 0.10.0
- tls-listener (crates.io): affected all versions; fixed in 0.10.0
- tls-listener (crates.io): affected from 0.0.0-0; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28854/ (Markdown: https://insights.sbomify.com/CVE-2024-28854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28854
- OSV: https://osv.dev/vulnerability/CVE-2024-28854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28854/
Summaries are generated and may contain mistakes; the official description above is the record.
