CVE-2024-28855 ZITADEL vulnerable to improper HTML sanitization
Attackers can inject HTML into the login UI due to improper template usage, though CSP prevents script execution, requiring a patch to fully mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-28855?
CVE-2024-28855 is a high-severity cross-site scripting vulnerability in zitadel, published on 18 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
ZITADEL, open source authentication management software, uses Go templates to render the login UI. Due to a improper use of the `text/template` instead of the `html/template` package, the Login UI did not sanitize input parameters prior to versions 2.47.3, 2.46.1, 2.45.1, 2.44.3, 2.43.9, 2.42.15, and 2.41.15. An attacker could create a malicious link, where he injected code which would be rendered as part of the login screen. While it was possible to inject HTML including JavaScript, the execution of such scripts would be prevented by the Content Security Policy. Versions 2.47.3, 2.46.1, 2.45.1, 2.44.3, 2.43.9, 2.42.15, and 2.41.15 contain a patch for this issue. No known workarounds are available.
Which versions are affected by CVE-2024-28855?
19 open source packages ship an affected version, including github.com/zitadel/zitadel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/zitadel/zitadel Go | All versions | 0.0.0-20240311065202-07ec2efa9dc6 |
github.com/zitadel/zitadel Go | All versions | 0.0.0-20240311065202-07ec2efa9dc6 |
github.com/zitadel/zitadel Go | All versions | 1.80.0-v2.20.0.20240312162750-5908b97e7c22 |
github.com/zitadel/zitadel Go | From 0.0.0 | 1.80.0-v2.20.0.20240311065202-07ec2efa9dc6 |
github.com/zitadel/zitadel Go | From 0.0.0 | 1.80.0-v2.20.0.20240311065202-07ec2efa9dc6 |
github.com/zitadel/zitadel Go | From 1.80.1 | 2.41.15 |
13 more packages
github.com/zitadel/zitadel Go | From 1.80.1 | 2.41.15 |
github.com/zitadel/zitadel Go | From 2.42.0 | 2.42.15 |
github.com/zitadel/zitadel Go | From 2.42.0 | 2.42.15 |
github.com/zitadel/zitadel Go | From 2.43.0 | 2.43.9 |
github.com/zitadel/zitadel Go | From 2.43.0 | 2.43.9 |
github.com/zitadel/zitadel Go | From 2.44.0 | 2.44.3 |
github.com/zitadel/zitadel Go | From 2.44.0 | 2.44.3 |
github.com/zitadel/zitadel Go | From 2.45.0 | 2.45.1 |
github.com/zitadel/zitadel Go | From 2.45.0 | 2.45.1 |
github.com/zitadel/zitadel Go | From 2.46.0 | 2.46.1 |
github.com/zitadel/zitadel Go | From 2.46.0 | 2.46.1 |
github.com/zitadel/zitadel Go | From 2.47.0 | 2.47.4 |
github.com/zitadel/zitadel Go | From 2.47.0 | 2.47.4 |
Products include Zitadel Zitadel.
How do I fix CVE-2024-28855?
Upgrade github.com/zitadel/zitadel to a fixed version for your release line: 0.0.0-20240311065202-07ec2efa9dc6, 1.80.0-v2.20.0.20240312162750-5908b97e7c22, 1.80.0-v2.20.0.20240311065202-07ec2efa9dc6 or 2.41.15.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-28855 being exploited?
There is no known exploitation of CVE-2024-28855 in the wild and no public exploit code.
Other vulnerabilities in zitadel
- CVE-2026-29191 ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint
- CVE-2025-67494 ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login
- CVE-2025-27507 IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations
- CVE-2025-64103 Zitadel Bypass Second Authentication Factor
- CVE-2025-31123 Zitadel Expired JWT Keys Usable for Authorization Grants
Sources
Also known as GHSA-hfrg-4jwr-jfpj, GO-2024-2655.