{"answers":{"affected":"2 open source packages ship an affected version, including friendsofsymfony1/symfony1. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28861 exists.","fix":"Upgrade friendsofsymfony1/symfony1 to 1.5.19 or later.","what":"CVE-2024-28861 is a critical unsafe deserialization vulnerability in FriendsOfSymfony1 symfony1, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28861 and fix it if it is affected.\n\nWhat it is: CVE-2024-28861 is a critical unsafe deserialization vulnerability in FriendsOfSymfony1 symfony1, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28861 exists.\n\nAffected packages and fixed versions:\n- friendsofsymfony1/symfony1 (Packagist): affected from 1.1.0; fixed in 1.5.19\n- friendsofsymfony1/symfony1 (Packagist): affected from 1.1.0; fixed in 1.5.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28861/ (Markdown: https://insights.sbomify.com/CVE-2024-28861/index.md)","id":"CVE-2024-28861","markdown":"https://insights.sbomify.com/CVE-2024-28861/index.md","name":"CVE-2024-28861","record":{"aliases":["GHSA-pv9j-c53q-h433"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"An attacker can achieve remote code execution if a developer deserializes untrusted user input using the sfNamespacedParameterHolder class in Symfony 1.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"symfony1","vendor":"friendsofsymfony1"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Symfony 1 is a community-driven fork of the 1.x branch of Symfony, a PHP framework for web projects. Starting in version 1.1.0 and prior to version 1.5.19, Symfony 1 has a gadget chain due to dangerous deserialization in `sfNamespacedParameterHolder` class that would enable an attacker to get remote code execution if a developer deserializes user input in their project. Version 1.5.19 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Gadget chain in Symfony 1 due to uncontrolled unserialized input in sfNamespacedParameterHolder","id":"CVE-2024-28861","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.","id":"CVE-2024-28862"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.19"],"introduced":["1.1.0"],"last_affected":[],"package":"friendsofsymfony1/symfony1","purl":null,"source":"GHSA-pv9j-c53q-h433"},{"ecosystem":"Packagist","fixed":["1.5.19"],"introduced":["1.1.0"],"last_affected":[],"package":"friendsofsymfony1/symfony1","purl":"pkg:composer/friendsofsymfony1/symfony1","source":"GHSA-pv9j-c53q-h433"}],"prev":{"headline":"Insecure IPsec transport encryption in Cilium","id":"CVE-2024-28860"},"products":["symfony1"],"published":"2024-03-22","related":[{"cvss_score":5,"headline":"Gadget chain in Symfony 1 due to vulnerable Swift Mailer dependency","id":"CVE-2024-28859","kev_date_added":null,"published":"2024-03-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-20","vendors":["FriendsOfSymfony1"]},"summary":"An attacker can achieve remote code execution if a developer deserializes untrusted user input using the sfNamespacedParameterHolder class in Symfony 1.","url":"https://insights.sbomify.com/CVE-2024-28861/"}