# CVE-2024-28861: Gadget chain in Symfony 1 due to uncontrolled unserialized input in sfNamespacedParameterHolder

> An attacker can achieve remote code execution if a developer deserializes untrusted user input using the sfNamespacedParameterHolder class in Symfony 1.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2024
- **Updated:** 20 Aug 2024
- **Also known as:** GHSA-pv9j-c53q-h433

## What is CVE-2024-28861?

CVE-2024-28861 is a critical unsafe deserialization vulnerability in FriendsOfSymfony1 symfony1, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony 1 is a community-driven fork of the 1.x branch of Symfony, a PHP framework for web projects. Starting in version 1.1.0 and prior to version 1.5.19, Symfony 1 has a gadget chain due to dangerous deserialization in `sfNamespacedParameterHolder` class that would enable an attacker to get remote code execution if a developer deserializes user input in their project. Version 1.5.19 contains a patch for the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-28861?

2 open source packages ship an affected version, including friendsofsymfony1/symfony1. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `friendsofsymfony1/symfony1` | Packagist | From 1.1.0 | 1.5.19 |
| `friendsofsymfony1/symfony1` | Packagist | From 1.1.0 | 1.5.19 |

Products: Friendsofsymfony1 Symfony1.

## How do I fix CVE-2024-28861?

Upgrade friendsofsymfony1/symfony1 to 1.5.19 or later.

## Is CVE-2024-28861 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28861 exists.

## Other vulnerabilities in FriendsOfSymfony1 symfony1

- [CVE-2024-28859](https://insights.sbomify.com/CVE-2024-28859/): Gadget chain in Symfony 1 due to vulnerable Swift Mailer dependency (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28861 and fix it if it is affected.

What it is: CVE-2024-28861 is a critical unsafe deserialization vulnerability in FriendsOfSymfony1 symfony1, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-28861 exists.

Affected packages and fixed versions:
- friendsofsymfony1/symfony1 (Packagist): affected from 1.1.0; fixed in 1.5.19
- friendsofsymfony1/symfony1 (Packagist): affected from 1.1.0; fixed in 1.5.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28861/ (Markdown: https://insights.sbomify.com/CVE-2024-28861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28861
- OSV: https://osv.dev/vulnerability/CVE-2024-28861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28861/
Summaries are generated and may contain mistakes; the official description above is the record.
