{"answers":{"affected":"2 open source packages ship an affected version, including rotp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28862 in the wild and no public exploit code.","fix":"Upgrade rotp to 6.3.0 or later.","what":"CVE-2024-28862 is a medium-severity vulnerability in mdp rotp, published on 15 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28862 and fix it if it is affected.\n\nWhat it is: CVE-2024-28862 is a medium-severity vulnerability in mdp rotp, published on 15 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28862 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rotp (RubyGems): affected from 6.2.1; fixed in 6.3.0\n- rotp (RubyGems): affected from 6.2.1; fixed in 6.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28862/ (Markdown: https://insights.sbomify.com/CVE-2024-28862/index.md)","id":"CVE-2024-28862","markdown":"https://insights.sbomify.com/CVE-2024-28862/index.md","name":"CVE-2024-28862","record":{"aliases":["GHSA-x2h8-qmj4-g62f"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby OTP library","requires_auth":"low_privilege","summary":"Attackers can read or modify OTP files due to overly permissive default permissions, potentially bypassing authentication.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rotp","vendor":"rotp_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"The Ruby One Time Password library (ROTP) is an open source library for generating and validating one time passwords. Affected versions had overly permissive default permissions. Users should patch to version 6.3.0. Users unable to patch may correct file permissions after installation.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.","id":"CVE-2024-28862","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"misconfiguration","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"node-tar vulnerable to denial of service while parsing a tar file due to lack of folders count validation","id":"CVE-2024-28863"},"packages":[{"ecosystem":"RubyGems","fixed":["6.3.0"],"introduced":["6.2.1"],"last_affected":[],"package":"rotp","purl":null,"source":"GHSA-x2h8-qmj4-g62f"},{"ecosystem":"RubyGems","fixed":["6.3.0"],"introduced":["6.2.1"],"last_affected":[],"package":"rotp","purl":"pkg:gem/rotp","source":"GHSA-x2h8-qmj4-g62f"}],"prev":{"headline":"Gadget chain in Symfony 1 due to uncontrolled unserialized input in sfNamespacedParameterHolder","id":"CVE-2024-28861"},"products":["rotp"],"published":"2024-03-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-21","vendors":["mdp"]},"summary":"Attackers can read or modify OTP files due to overly permissive default permissions, potentially bypassing authentication.","url":"https://insights.sbomify.com/CVE-2024-28862/"}