# CVE-2024-28862: ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.

> Attackers can read or modify OTP files due to overly permissive default permissions, potentially bypassing authentication.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-x2h8-qmj4-g62f

## What is CVE-2024-28862?

CVE-2024-28862 is a medium-severity vulnerability in mdp rotp, published on 15 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Ruby One Time Password library (ROTP) is an open source library for generating and validating one time passwords. Affected versions had overly permissive default permissions. Users should patch to version 6.3.0. Users unable to patch may correct file permissions after installation.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-28862?

2 open source packages ship an affected version, including rotp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rotp` | RubyGems | From 6.2.1 | 6.3.0 |
| `rotp` | RubyGems | From 6.2.1 | 6.3.0 |

Products: Rotp Project Rotp.

## How do I fix CVE-2024-28862?

Upgrade rotp to 6.3.0 or later.

## Is CVE-2024-28862 being exploited?

There is no known exploitation of CVE-2024-28862 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28862 and fix it if it is affected.

What it is: CVE-2024-28862 is a medium-severity vulnerability in mdp rotp, published on 15 Mar 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-28862 in the wild and no public exploit code.

Affected packages and fixed versions:
- rotp (RubyGems): affected from 6.2.1; fixed in 6.3.0
- rotp (RubyGems): affected from 6.2.1; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28862/ (Markdown: https://insights.sbomify.com/CVE-2024-28862/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28862
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28862
- OSV: https://osv.dev/vulnerability/CVE-2024-28862

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28862/
Summaries are generated and may contain mistakes; the official description above is the record.
