# CVE-2024-28865: django-wiki denial of service via regular expression


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Mar 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-wj85-w4f4-xh8h, PYSEC-2026-2049

## What is CVE-2024-28865?

CVE-2024-28865 is a high-severity vulnerability in django-wiki, published on 18 Mar 2024. 

### Official description

django-wiki is a wiki system for Django. Installations of django-wiki prior to version 0.10.1 are vulnerable to maliciously crafted article content that can cause severe use of server CPU through a regular expression loop. Version 0.10.1 fixes this issue. As a workaround, close off access to create and edit articles by anonymous users.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2024-28865?

3 open source packages ship an affected version, including wiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wiki` | PyPI | All versions | 0.10.1 |
| `wiki` | PyPI | All versions | 0.10.1 |
| `wiki` | PyPI | All versions | 0.10.1 |

Products: Django-Wiki Project Django-Wiki.

## How do I fix CVE-2024-28865?

Upgrade wiki to 0.10.1 or later.

## Is CVE-2024-28865 being exploited?

There is no known exploitation of CVE-2024-28865 in the wild and no public exploit code.

## Other vulnerabilities in django-wiki

- [CVE-2021-25986](https://insights.sbomify.com/CVE-2021-25986/): Django-wiki - Stored Cross-Site Scripting (XSS) in Notifications Section (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-28865 and fix it if it is affected.

What it is: CVE-2024-28865 is a high-severity vulnerability in django-wiki, published on 18 Mar 2024. 
Exploitation: There is no known exploitation of CVE-2024-28865 in the wild and no public exploit code.

Affected packages and fixed versions:
- wiki (PyPI): affected all versions; fixed in 0.10.1
- wiki (PyPI): affected all versions; fixed in 0.10.1
- wiki (PyPI): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-28865/ (Markdown: https://insights.sbomify.com/CVE-2024-28865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-28865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-28865
- OSV: https://osv.dev/vulnerability/CVE-2024-28865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-28865/
Summaries are generated and may contain mistakes; the official description above is the record.
