{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-28882 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-28882 is a medium-severity denial of service vulnerability in OpenVPN, published on 8 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-28882 and fix it if it is affected.\n\nWhat it is: CVE-2024-28882 is a medium-severity denial of service vulnerability in OpenVPN, published on 8 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-28882 in the wild and no public exploit code.\n\nAffected product: OpenVPN. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-28882/ (Markdown: https://insights.sbomify.com/CVE-2024-28882/index.md)","id":"CVE-2024-28882","markdown":"https://insights.sbomify.com/CVE-2024-28882/index.md","name":"CVE-2024-28882","record":{"aliases":["ALPINE-CVE-2024-28882","DEBIAN-CVE-2024-28882","GHSA-v34q-j8xh-hjgx","OESA-2024-1840","SUSE-SU-2024:3502-1","SUSE-SU-2024:3532-1","UBUNTU-CVE-2024-28882","openSUSE-SU-2024:14436-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenVPN server","requires_auth":"low_privilege","summary":"An authenticated client can extend session validity by sending multiple exit notifications, potentially causing resource exhaustion and denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"OpenVPN","cpe":[{"product":"openvpn","vendor":"openvpn"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-772","name":"Missing Release of Resource after Effective Lifetime"}],"description":"OpenVPN from 2.6.0 through 2.6.10 in a server role accepts multiple exit notifications from authenticated clients which will extend the validity of a closing session","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP6","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in OpenVPN","id":"CVE-2024-28882","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":5,"n_references":2,"next":{"headline":"BIG-IP APM browser network access VPN client vulnerability","id":"CVE-2024-28883"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["2.6.8-150600.3.3.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2024:3502-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["2.3.8-16.32.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:3532-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["2.3.8-16.32.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/suse/openvpn\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:3532-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["2.6.8-150600.3.3.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/opensuse/openvpn\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:3502-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.6.10-2.1"],"introduced":["0"],"last_affected":[],"package":"openvpn","purl":"pkg:rpm/opensuse/openvpn\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14436-1"}],"prev":{"headline":"Privilege escalation in Intel(R) Fortran Compiler Classic software","id":"CVE-2024-28881"},"products":["OpenVPN"],"published":"2024-07-08","related":[{"cvss_score":9.1,"headline":"Memory corruption in OpenVPN","id":"CVE-2025-12106","kev_date_added":null,"published":"2025-12-01"},{"cvss_score":9.1,"headline":"Information disclosure in OpenVPN","id":"CVE-2024-5594","kev_date_added":null,"published":"2025-01-06"},{"cvss_score":9.1,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-7544","kev_date_added":null,"published":"2018-03-16"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2006-1629","kev_date_added":null,"published":"2006-04-06"},{"cvss_score":8.8,"headline":"Privilege escalation in OpenVPN","id":"CVE-2024-4877","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":7.8,"headline":"Code injection in OpenVPN-GUI","id":"CVE-2021-3606","kev_date_added":null,"published":"2021-07-02"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2018-9336","kev_date_added":null,"published":"2018-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-01","vendors":["OpenVPN"]},"summary":"An authenticated client can extend session validity by sending multiple exit notifications, potentially causing resource exhaustion and denial of service.","url":"https://insights.sbomify.com/CVE-2024-28882/"}