CVE-2024-28949 DoS via a large number of User Preferences
An attacker can cause denial of service by sending a large number of user preferences due to missing limits in Mattermost Server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-28949?
CVE-2024-28949 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 5 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost Server versions 9.5.x before 9.5.2, 9.4.x before 9.4.4, 9.3.x before 9.3.3, 8.1.x before 8.1.11 don't limit the number of user preferences which allows an attacker to send a large number of user preferences potentially causing denial of service.
Which versions are affected by CVE-2024-28949?
13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | From 8.1.0 | 8.1.11 |
github.com/mattermost/mattermost/server/v8 Go | From 8.1.0 | 8.1.11 |
github.com/mattermost/mattermost/server/v8 Go | From 9.3.0 | 9.3.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.3.0 | 9.3.3 |
github.com/mattermost/mattermost/server/v8 Go | From 9.4.0 | 9.4.4 |
7 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.4.0 | 9.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.5.0 | 9.5.2 |
mattermost Bitnami | From 8.1.0 | 8.1.11, 9.3.3, 9.4.4, 9.5.2 |
github.com/mattermost/mattermost-server Go | From 9.3.0+incompatible | 9.3.3+incompatible, 9.4.4+incompatible, 9.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2024-28949?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.1.11, 9.3.3, 9.4.4 or 9.5.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-28949 being exploited?
There is no known exploitation of CVE-2024-28949 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as BIT-mattermost-2024-28949, GHSA-mcw6-3256-64gg, GO-2024-2695.