{"answers":{"affected":"3 open source packages ship an affected version, including esphome.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29019 exists.","fix":"Upgrade esphome to 2024.3.0 or later.","what":"CVE-2024-29019 is a high-severity vulnerability in esphome, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-29019 and fix it if it is affected.\n\nWhat it is: CVE-2024-29019 is a high-severity vulnerability in esphome, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29019 exists.\n\nAffected packages and fixed versions:\n- esphome (PyPI): affected from 2023.12.9; fixed in 2024.3.0\n- esphome (PyPI): affected from 2023.12.9; fixed in 2024.3.0\n- esphome (PyPI): affected from 2023.12.9; fixed in 2024.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29019/ (Markdown: https://insights.sbomify.com/CVE-2024-29019/index.md)","id":"CVE-2024-29019","markdown":"https://insights.sbomify.com/CVE-2024-29019/index.md","name":"CVE-2024-29019","record":{"aliases":["GHSA-5925-88xh-6h99","PYSEC-2026-1327"],"analysis":{"component_type":"iot_embedded","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"ESPHome dashboard","requires_auth":"none","summary":"Attackers can bypass authentication and modify configuration files via CSRF, potentially leading to account takeover.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"ESPHome is a system to control microcontrollers remotely through Home Automation systems. API endpoints in dashboard component of ESPHome version 2023.12.9 (command line installation) are vulnerable to Cross-Site Request Forgery (CSRF) allowing remote attackers to carry out attacks against a logged user of the dashboard to perform operations on configuration files (create, edit, delete). It is possible for a malicious actor to create a specifically crafted web page that triggers a cross site request against ESPHome, this allows bypassing the authentication for API calls on the platform. This vulnerability allows bypassing authentication on API calls accessing configuration file operations on the behalf of a logged user. In order to trigger the vulnerability, the victim must visit a weaponized page. In addition to this, it is possible to chain this vulnerability with GHSA-9p43-hj5j-96h5/ CVE-2024-27287 to obtain a complete takeover of the user account. Version 2024.3.0 contains a patch for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ESPHome vulnerable to Authentication bypass via Cross site request forgery","id":"CVE-2024-29019","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"JumpServer allows nn authorized attacker to get sensitive information in playbook files when playbook_id is leaked","id":"CVE-2024-29020"},"packages":[{"ecosystem":"PyPI","fixed":["2024.3.0"],"introduced":["2023.12.9"],"last_affected":[],"package":"esphome","purl":null,"source":"GHSA-5925-88xh-6h99"},{"ecosystem":"PyPI","fixed":["2024.3.0"],"introduced":["2023.12.9"],"last_affected":[],"package":"esphome","purl":"pkg:pypi/esphome","source":"GHSA-5925-88xh-6h99"},{"ecosystem":"PyPI","fixed":["2024.3.0"],"introduced":["2023.12.9"],"last_affected":[],"package":"esphome","purl":"pkg:pypi/esphome","source":"PYSEC-2026-1327"}],"prev":{"headline":"External DNS requests from 'internal' networks could lead to data exfiltration","id":"CVE-2024-29018"},"products":["esphome"],"published":"2024-03-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["esphome"]},"summary":"Attackers can bypass authentication and modify configuration files via CSRF, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2024-29019/"}