# CVE-2024-29019: ESPHome vulnerable to Authentication bypass via Cross site request forgery

> Attackers can bypass authentication and modify configuration files via CSRF, potentially leading to account takeover.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Mar 2024
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-5925-88xh-6h99, PYSEC-2026-1327

## What is CVE-2024-29019?

CVE-2024-29019 is a high-severity vulnerability in esphome, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ESPHome is a system to control microcontrollers remotely through Home Automation systems. API endpoints in dashboard component of ESPHome version 2023.12.9 (command line installation) are vulnerable to Cross-Site Request Forgery (CSRF) allowing remote attackers to carry out attacks against a logged user of the dashboard to perform operations on configuration files (create, edit, delete). It is possible for a malicious actor to create a specifically crafted web page that triggers a cross site request against ESPHome, this allows bypassing the authentication for API calls on the platform. This vulnerability allows bypassing authentication on API calls accessing configuration file operations on the behalf of a logged user. In order to trigger the vulnerability, the victim must visit a weaponized page. In addition to this, it is possible to chain this vulnerability with GHSA-9p43-hj5j-96h5/ CVE-2024-27287 to obtain a complete takeover of the user account. Version 2024.3.0 contains a patch for this issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-29019?

3 open source packages ship an affected version, including esphome.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `esphome` | PyPI | From 2023.12.9 | 2024.3.0 |
| `esphome` | PyPI | From 2023.12.9 | 2024.3.0 |
| `esphome` | PyPI | From 2023.12.9 | 2024.3.0 |

## How do I fix CVE-2024-29019?

Upgrade esphome to 2024.3.0 or later.

## Is CVE-2024-29019 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29019 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29019 and fix it if it is affected.

What it is: CVE-2024-29019 is a high-severity vulnerability in esphome, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29019 exists.

Affected packages and fixed versions:
- esphome (PyPI): affected from 2023.12.9; fixed in 2024.3.0
- esphome (PyPI): affected from 2023.12.9; fixed in 2024.3.0
- esphome (PyPI): affected from 2023.12.9; fixed in 2024.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29019/ (Markdown: https://insights.sbomify.com/CVE-2024-29019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29019
- OSV: https://osv.dev/vulnerability/CVE-2024-29019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29019/
Summaries are generated and may contain mistakes; the official description above is the record.
