CVE-2024-29027 Parse Server crash and RCE via invalid Cloud Function or Cloud Job name

Critical 9.1 Published Updated

Attackers can trigger server crashes or execute arbitrary code by providing invalid Cloud Function or Job names in Parse Server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29027?

CVE-2024-29027 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 19 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 6.5.5 and 7.0.0-alpha.29, calling an invalid Parse Server Cloud Function name or Cloud Job name crashes the server and may allow for code injection, internal store manipulation or remote code execution. The patch in versions 6.5.5 and 7.0.0-alpha.29 added string sanitation for Cloud Function name and Cloud Job name. As a workaround, sanitize the Cloud Function name and Cloud Job name before it reaches Parse Server.

Weakness: CWE-74

Which versions are affected by CVE-2024-29027?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions6.5.5
parse-server npmAll versions6.5.5
parse-server npmFrom 7.0.0-alpha.17.0.0-alpha.29
parse-server npmFrom 7.0.0-alpha.17.0.0-alpha.29
parse BitnamiAll versions6.5.5

Products include Parseplatform Parse-Server.

How do I fix CVE-2024-29027?

Upgrade parse-server to a fixed version for your release line: 6.5.5 or 7.0.0-alpha.29.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-29027 being exploited?

There is no known exploitation of CVE-2024-29027 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2024-29027, GHSA-6hh7-46r2-vf29.

Is CVE-2024-29027 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free