# CVE-2024-29027: Parse Server crash and RCE via invalid Cloud Function or Cloud Job name

> Attackers can trigger server crashes or execute arbitrary code by providing invalid Cloud Function or Job names in Parse Server.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-parse-2024-29027, GHSA-6hh7-46r2-vf29

## What is CVE-2024-29027?

CVE-2024-29027 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 19 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 6.5.5 and 7.0.0-alpha.29, calling an invalid Parse Server Cloud Function name or Cloud Job name crashes the server and may allow for code injection, internal store manipulation or remote code execution. The patch in versions 6.5.5 and 7.0.0-alpha.29 added string sanitation for Cloud Function name and Cloud Job name. As a workaround, sanitize the Cloud Function name and Cloud Job name before it reaches Parse Server.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-29027?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 6.5.5 |
| `parse-server` | npm | All versions | 6.5.5 |
| `parse-server` | npm | From 7.0.0-alpha.1 | 7.0.0-alpha.29 |
| `parse-server` | npm | From 7.0.0-alpha.1 | 7.0.0-alpha.29 |
| `parse` | Bitnami | All versions | 6.5.5 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2024-29027?

Upgrade parse-server to a fixed version for your release line: 6.5.5 or 7.0.0-alpha.29.

## Is CVE-2024-29027 being exploited?

There is no known exploitation of CVE-2024-29027 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29027 and fix it if it is affected.

What it is: CVE-2024-29027 is a critical code injection vulnerability in Parseplatform Parse-Server, published on 19 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29027 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 6.5.5
- parse-server (npm): affected all versions; fixed in 6.5.5
- parse-server (npm): affected from 7.0.0-alpha.1; fixed in 7.0.0-alpha.29
- parse-server (npm): affected from 7.0.0-alpha.1; fixed in 7.0.0-alpha.29
- parse (Bitnami): affected all versions; fixed in 6.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29027/ (Markdown: https://insights.sbomify.com/CVE-2024-29027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29027
- OSV: https://osv.dev/vulnerability/CVE-2024-29027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29027/
Summaries are generated and may contain mistakes; the official description above is the record.
