# CVE-2024-29029: memos vulnerable to an SSRF in /o/get/image

> Unauthenticated attackers can exploit SSRF in the image endpoint to enumerate internal networks and trigger reflected XSS, requiring an upgrade to secure the service.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9cqm-mgv9-vv9j, GO-2024-3049

## What is CVE-2024-29029?

CVE-2024-29029 is a medium-severity server-side request forgery vulnerability in Usememos Memos, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /o/get/image that allows unauthenticated users to enumerate the internal network and retrieve images. The response from the image request is then copied into the response of the current server request, causing a reflected XSS vulnerability. Version 0.22.0 of memos removes the vulnerable file.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-29029?

3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/usememos/memos` | Go | All versions | 0.22.0 |
| `github.com/usememos/memos` | Go | All versions | 0.22.0 |
| `github.com/usememos/memos` | Go | All versions | 0.22.0 |

Products: Usememos Memos.

## How do I fix CVE-2024-29029?

Upgrade github.com/usememos/memos to 0.22.0 or later.

## Is CVE-2024-29029 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29029 exists.

Public exploit code:

- Memos 0.13.2 - Cross-Site Scripting & SSRF (nuclei): http/cves/2024/CVE-2024-29029.yaml

## Other vulnerabilities in Usememos Memos

- [CVE-2025-50738](https://insights.sbomify.com/CVE-2025-50738/): Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs (critical 9.8)
- [CVE-2025-22952](https://insights.sbomify.com/CVE-2025-22952/): Memos Server-Side Request Forgery (SSRF) (critical 9.8)
- [CVE-2023-0109](https://insights.sbomify.com/CVE-2023-0109/): Stored XSS in usememos/memos (critical 9.8)
- [CVE-2023-4696](https://insights.sbomify.com/CVE-2023-4696/): Improper Access Control in usememos/memos (critical 9.8)
- [CVE-2022-4866](https://insights.sbomify.com/CVE-2022-4866/): Cross-site Scripting (XSS) - Stored in usememos/memos (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29029 and fix it if it is affected.

What it is: CVE-2024-29029 is a medium-severity server-side request forgery vulnerability in Usememos Memos, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29029 exists.

Affected packages and fixed versions:
- github.com/usememos/memos (Go): affected all versions; fixed in 0.22.0
- github.com/usememos/memos (Go): affected all versions; fixed in 0.22.0
- github.com/usememos/memos (Go): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29029/ (Markdown: https://insights.sbomify.com/CVE-2024-29029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29029
- OSV: https://osv.dev/vulnerability/CVE-2024-29029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29029/
Summaries are generated and may contain mistakes; the official description above is the record.
