CVE-2024-29030 memos vulnerable to an SSRF in /api/resource

Medium 5.8 Published Updated

Authenticated users can exploit an SSRF vulnerability in the /api/resource endpoint to enumerate the internal network.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29030?

CVE-2024-29030 is a medium-severity server-side request forgery vulnerability in Usememos Memos, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /api/resource that allows authenticated users to enumerate the internal network. Version 0.22.0 of memos removes the vulnerable file.

Weakness: CWE-918

Which versions are affected by CVE-2024-29030?

3 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.

PackageAffectedFixed in
github.com/usememos/memos GoAll versions0.22.0
github.com/usememos/memos GoAll versions0.22.0
github.com/usememos/memos GoAll versions0.22.0

Products include Usememos Memos.

How do I fix CVE-2024-29030?

Upgrade github.com/usememos/memos to 0.22.0 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-29030 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29030 exists.

Public exploit code: 1 Nuclei template.

All Usememos Memos vulnerabilities

Sources

Also known as GHSA-65fm-2jgr-j7qq, GO-2024-3046.

Is CVE-2024-29030 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free