# CVE-2024-29031: Meshery SQL Injection vulnerability

> Remote attackers can exploit a SQL injection flaw in Meshery to obtain sensitive information via the order parameter.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2024
- **Updated:** 13 Aug 2024
- **Also known as:** GHSA-652r-q29p-m25h, GO-2024-3045

## What is CVE-2024-29031?

CVE-2024-29031 is a high-severity SQL injection vulnerability in meshery, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Meshery is an open source, cloud native manager that enables the design and management of Kubernetes-based infrastructure and applications. A SQL injection vulnerability in Meshery prior to version 0.7.17 allows a remote attacker to obtain sensitive information via the `order` parameter of `GetMeshSyncResources`. Version 0.7.17 contains a patch for this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-29031?

3 open source packages ship an affected version, including github.com/layer5io/meshery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/layer5io/meshery` | Go | All versions | 0.7.17 |
| `github.com/layer5io/meshery` | Go | All versions | 0.7.17 |
| `github.com/layer5io/meshery` | Go | All versions | 0.7.17 |

Products: Layer5 Meshery.

## How do I fix CVE-2024-29031?

Upgrade github.com/layer5io/meshery to 0.7.17 or later.

## Is CVE-2024-29031 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29031 exists.

## Other vulnerabilities in meshery

- [CVE-2024-36535](https://insights.sbomify.com/CVE-2024-36535/): Missing authorization in n/a (critical 9.8)
- [CVE-2023-46575](https://insights.sbomify.com/CVE-2023-46575/): SQL injection vulnerability in Meshery (critical 9.8)
- [CVE-2021-31856](https://insights.sbomify.com/CVE-2021-31856/): SQL injection in n/a (critical 9.8)
- [CVE-2024-35181](https://insights.sbomify.com/CVE-2024-35181/): GHSL-2024-013 Meshery SQL Injection vulnerability (medium 5.9)
- [CVE-2024-35182](https://insights.sbomify.com/CVE-2024-35182/): GHSL-2024-014 Meshery SQL Injection vulnerability (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29031 and fix it if it is affected.

What it is: CVE-2024-29031 is a high-severity SQL injection vulnerability in meshery, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29031 exists.

Affected packages and fixed versions:
- github.com/layer5io/meshery (Go): affected all versions; fixed in 0.7.17
- github.com/layer5io/meshery (Go): affected all versions; fixed in 0.7.17
- github.com/layer5io/meshery (Go): affected all versions; fixed in 0.7.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29031/ (Markdown: https://insights.sbomify.com/CVE-2024-29031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29031
- OSV: https://osv.dev/vulnerability/CVE-2024-29031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29031/
Summaries are generated and may contain mistakes; the official description above is the record.
