{"answers":{"affected":"3 open source packages ship an affected version, including oauthenticator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-29033 in the wild and no public exploit code.","fix":"Upgrade oauthenticator to 16.3.0 or later.","what":"CVE-2024-29033 is a high-severity authentication bypass vulnerability in jupyterhub oauthenticator, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29033 and fix it if it is affected.\n\nWhat it is: CVE-2024-29033 is a high-severity authentication bypass vulnerability in jupyterhub oauthenticator, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29033 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- oauthenticator (PyPI): affected all versions; fixed in 16.3.0\n- oauthenticator (PyPI): affected all versions; fixed in 16.3.0\n- oauthenticator (PyPI): affected all versions; fixed in 16.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29033/ (Markdown: https://insights.sbomify.com/CVE-2024-29033/index.md)","id":"CVE-2024-29033","markdown":"https://insights.sbomify.com/CVE-2024-29033/index.md","name":"CVE-2024-29033","record":{"aliases":["GHSA-55m3-44xf-hg4h","PYSEC-2026-1710"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterHub OAuth plugin","requires_auth":"none","summary":"Attackers can bypass domain restrictions in GoogleOAuthenticator by using email addresses that merely end with the allowed domain, gaining unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"oauthenticator","vendor":"jupyter"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"OAuthenticator provides plugins for JupyterHub to use common OAuth providers, as well as base classes for writing one's own Authenticators with any OAuth 2.0 provider. `GoogleOAuthenticator.hosted_domain` is used to restrict what Google accounts can be authorized access to a JupyterHub. The restriction is intented to be to Google accounts part of one or more Google organization verified to control specified domain(s). Prior to version 16.3.0, the actual restriction has been to Google accounts with emails ending with the domain. Such accounts could have been created by anyone which at one time was able to read an email associated with the domain. This was described by Dylan Ayrey (@dxa4481) in this [blog post] from 15th December 2023). OAuthenticator 16.3.0 contains a patch for this issue. As a workaround, restrict who can login another way, such as `allowed_users` or `allowed_google_groups`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace","id":"CVE-2024-29033","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"CarrierWave's Content-Type allowlist bypass vulnerability which possibly leads to XSS remained","id":"CVE-2024-29034"},"packages":[{"ecosystem":"PyPI","fixed":["16.3.0"],"introduced":["0"],"last_affected":[],"package":"oauthenticator","purl":null,"source":"GHSA-55m3-44xf-hg4h"},{"ecosystem":"PyPI","fixed":["16.3.0"],"introduced":["0"],"last_affected":[],"package":"oauthenticator","purl":"pkg:pypi/oauthenticator","source":"GHSA-55m3-44xf-hg4h"},{"ecosystem":"PyPI","fixed":["16.3.0"],"introduced":["0"],"last_affected":[],"package":"oauthenticator","purl":"pkg:pypi/oauthenticator","source":"PYSEC-2026-1710"}],"prev":{"headline":"`qiskit_ibm_runtime.RuntimeDecoder` can execute arbitrary code","id":"CVE-2024-29032"},"products":["oauthenticator"],"published":"2024-03-20","related":[{"cvss_score":8.8,"headline":"OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims","id":"CVE-2026-33175","kev_date_added":null,"published":"2026-04-03"},{"cvss_score":8.8,"headline":"JupyterHub OAuthenticator elevation of privilege","id":"CVE-2018-7206","kev_date_added":null,"published":"2018-02-18"},{"cvss_score":6.3,"headline":"Base class whitelist configuration ignored in OAuthenticator","id":"CVE-2020-26250","kev_date_added":null,"published":"2020-12-01"},{"cvss_score":4.2,"headline":"Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator","id":"CVE-2022-31027","kev_date_added":null,"published":"2022-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["jupyterhub"]},"summary":"Attackers can bypass domain restrictions in GoogleOAuthenticator by using email addresses that merely end with the allowed domain, gaining unauthorized access.","url":"https://insights.sbomify.com/CVE-2024-29033/"}