# CVE-2024-29033: GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace

> Attackers can bypass domain restrictions in GoogleOAuthenticator by using email addresses that merely end with the allowed domain, gaining unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-55m3-44xf-hg4h, PYSEC-2026-1710

## What is CVE-2024-29033?

CVE-2024-29033 is a high-severity authentication bypass vulnerability in jupyterhub oauthenticator, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OAuthenticator provides plugins for JupyterHub to use common OAuth providers, as well as base classes for writing one's own Authenticators with any OAuth 2.0 provider. `GoogleOAuthenticator.hosted_domain` is used to restrict what Google accounts can be authorized access to a JupyterHub. The restriction is intented to be to Google accounts part of one or more Google organization verified to control specified domain(s). Prior to version 16.3.0, the actual restriction has been to Google accounts with emails ending with the domain. Such accounts could have been created by anyone which at one time was able to read an email associated with the domain. This was described by Dylan Ayrey (@dxa4481) in this [blog post] from 15th December 2023). OAuthenticator 16.3.0 contains a patch for this issue. As a workaround, restrict who can login another way, such as `allowed_users` or `allowed_google_groups`.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-29033?

3 open source packages ship an affected version, including oauthenticator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauthenticator` | PyPI | All versions | 16.3.0 |
| `oauthenticator` | PyPI | All versions | 16.3.0 |
| `oauthenticator` | PyPI | All versions | 16.3.0 |

Products: Jupyter Oauthenticator.

## How do I fix CVE-2024-29033?

Upgrade oauthenticator to 16.3.0 or later.

## Is CVE-2024-29033 being exploited?

There is no known exploitation of CVE-2024-29033 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub oauthenticator

- [CVE-2026-33175](https://insights.sbomify.com/CVE-2026-33175/): OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims (high 8.8)
- [CVE-2018-7206](https://insights.sbomify.com/CVE-2018-7206/): JupyterHub OAuthenticator elevation of privilege (high 8.8)
- [CVE-2020-26250](https://insights.sbomify.com/CVE-2020-26250/): Base class whitelist configuration ignored in OAuthenticator (medium 6.3)
- [CVE-2022-31027](https://insights.sbomify.com/CVE-2022-31027/): Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29033 and fix it if it is affected.

What it is: CVE-2024-29033 is a high-severity authentication bypass vulnerability in jupyterhub oauthenticator, published on 20 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29033 in the wild and no public exploit code.

Affected packages and fixed versions:
- oauthenticator (PyPI): affected all versions; fixed in 16.3.0
- oauthenticator (PyPI): affected all versions; fixed in 16.3.0
- oauthenticator (PyPI): affected all versions; fixed in 16.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29033/ (Markdown: https://insights.sbomify.com/CVE-2024-29033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29033
- OSV: https://osv.dev/vulnerability/CVE-2024-29033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29033/
Summaries are generated and may contain mistakes; the official description above is the record.
