{"answers":{"affected":"2 open source packages ship an affected version, including translate. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29042 exists.","fix":"Upgrade translate to 3.0.0 or later.","what":"CVE-2024-29042 is a medium-severity vulnerability in franciscop translate, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29042 and fix it if it is affected.\n\nWhat it is: CVE-2024-29042 is a medium-severity vulnerability in franciscop translate, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29042 exists.\n\nAffected packages and fixed versions:\n- translate (npm): affected all versions; fixed in 3.0.0\n- translate (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29042/ (Markdown: https://insights.sbomify.com/CVE-2024-29042/index.md)","id":"CVE-2024-29042","markdown":"https://insights.sbomify.com/CVE-2024-29042/index.md","name":"CVE-2024-29042","record":{"aliases":["GHSA-882j-4vj5-7vmj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js translation library","requires_auth":"none","summary":"An attacker can poison the translation cache to serve malicious or incorrect translations to other users by manipulating the cache key.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"translate","vendor":"francisco"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Translate is a package that allows users to convert text to different languages on Node.js and the browser. Prior to version 3.0.0, an attacker controlling the second variable of the `translate` function is able to perform a cache poisoning attack. They can change the outcome of translation requests made by subsequent users. The `opt.id` parameter allows the overwriting of the cache key. If an attacker sets the `id` variable to the cache key that would be generated by another user, they can choose the response that user gets served. Version 3.0.0 fixes this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Translate Cache Poisoning Vulnerability","id":"CVE-2024-29042","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Microsoft ODBC Driver for SQL Server Remote Code Execution Vulnerability","id":"CVE-2024-29043"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"translate","purl":null,"source":"GHSA-882j-4vj5-7vmj"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"translate","purl":"pkg:npm/translate","source":"GHSA-882j-4vj5-7vmj"}],"prev":{"headline":"Express.js Open Redirect in malformed URLs","id":"CVE-2024-29041"},"products":["translate"],"published":"2024-03-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["franciscop"]},"summary":"An attacker can poison the translation cache to serve malicious or incorrect translations to other users by manipulating the cache key.","url":"https://insights.sbomify.com/CVE-2024-29042/"}