# CVE-2024-29068: snapd non-regular file indefinite blocking read

> An attacker can cause snapd to hang indefinitely by tricking a user into installing a malicious snap containing non-regular files, leading to denial of service.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-29068, GHSA-64jh-cjwc-w8q6, GO-2024-3008, UBUNTU-CVE-2024-29068

## What is CVE-2024-29068?

CVE-2024-29068 is a medium-severity denial of service vulnerability in Canonical snapd, published on 25 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In snapd versions prior to 2.62, snapd failed to properly check the file
type when extracting a snap. The snap format is a squashfs file-system
image and so can contain files that are non-regular files (such as pipes 
or sockets etc). Various file entries within the snap squashfs image
(such as icons etc) are directly read by snapd when it is extracted. An 
attacker who could convince a user to install a malicious snap which
contained non-regular files at these paths could then cause snapd to block
indefinitely trying to read from such files and cause a denial of service.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-29068?

3 open source packages ship an affected version, including github.com/snapcore/snapd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/snapcore/snapd` | Go | All versions | None |
| `github.com/snapcore/snapd` | Go | All versions | 2.62 |
| `github.com/snapcore/snapd` | Go | All versions | 2.62 |

Products: Canonical Snapd.

## How do I fix CVE-2024-29068?

Upgrade github.com/snapcore/snapd to 2.62 or later.

## Is CVE-2024-29068 being exploited?

There is no known exploitation of CVE-2024-29068 in the wild and no public exploit code.

## Other vulnerabilities in Canonical snapd

- [CVE-2023-1523](https://insights.sbomify.com/CVE-2023-1523/): Command injection in snapd (critical 10.0)
- [CVE-2020-27352](https://insights.sbomify.com/CVE-2020-27352/): Privilege escalation in snapd (critical 9.3)
- [CVE-2019-7304](https://insights.sbomify.com/CVE-2019-7304/): Local privilege escalation via snapd socket (high 8.8)
- [CVE-2021-4120](https://insights.sbomify.com/CVE-2021-4120/): snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths (high 8.2)
- [CVE-2024-5138](https://insights.sbomify.com/CVE-2024-5138/): CVE-2024-5138: snapd snapctl auth bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29068 and fix it if it is affected.

What it is: CVE-2024-29068 is a medium-severity denial of service vulnerability in Canonical snapd, published on 25 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-29068 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/snapcore/snapd (Go): affected all versions; no fix listed
- github.com/snapcore/snapd (Go): affected all versions; fixed in 2.62
- github.com/snapcore/snapd (Go): affected all versions; fixed in 2.62

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29068/ (Markdown: https://insights.sbomify.com/CVE-2024-29068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29068
- OSV: https://osv.dev/vulnerability/CVE-2024-29068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29068/
Summaries are generated and may contain mistakes; the official description above is the record.
