# CVE-2024-29069: snapd will follow archived symlinks when unpacking a filesystem

> An attacker can trick users into installing a malicious snap to read privileged files via symlink following, exposing sensitive data to unprivileged users.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-29069, GHSA-69p6-gp5x-j269, GO-2024-3009, UBUNTU-CVE-2024-29069

## What is CVE-2024-29069?

CVE-2024-29069 is a medium-severity path traversal vulnerability in Canonical snapd, published on 25 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In snapd versions prior to 2.62, snapd failed to properly check the
destination of symbolic links when extracting a snap. The snap format 
is a squashfs file-system image and so can contain symbolic links and
other file types. Various file entries within the snap squashfs image
(such as icons and desktop files etc) are directly read by snapd when
it is extracted. An attacker who could convince a user to install a
malicious snap which contained symbolic links at these paths could then 
cause snapd to write out the contents of the symbolic link destination
into a world-readable directory. This in-turn could allow an unprivileged
user to gain access to privileged information.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-610 (Externally Controlled Reference to a Resource in Another Sphere)

## Which versions are affected by CVE-2024-29069?

3 open source packages ship an affected version, including github.com/snapcore/snapd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/snapcore/snapd` | Go | All versions | None |
| `github.com/snapcore/snapd` | Go | All versions | 2.62 |
| `github.com/snapcore/snapd` | Go | All versions | 2.62 |

Products: Canonical Snapd.

## How do I fix CVE-2024-29069?

Upgrade github.com/snapcore/snapd to 2.62 or later.

## Is CVE-2024-29069 being exploited?

There is no known exploitation of CVE-2024-29069 in the wild and no public exploit code.

## Other vulnerabilities in Canonical snapd

- [CVE-2023-1523](https://insights.sbomify.com/CVE-2023-1523/): Command injection in snapd (critical 10.0)
- [CVE-2020-27352](https://insights.sbomify.com/CVE-2020-27352/): Privilege escalation in snapd (critical 9.3)
- [CVE-2019-7304](https://insights.sbomify.com/CVE-2019-7304/): Local privilege escalation via snapd socket (high 8.8)
- [CVE-2021-4120](https://insights.sbomify.com/CVE-2021-4120/): snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths (high 8.2)
- [CVE-2024-5138](https://insights.sbomify.com/CVE-2024-5138/): CVE-2024-5138: snapd snapctl auth bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29069 and fix it if it is affected.

What it is: CVE-2024-29069 is a medium-severity path traversal vulnerability in Canonical snapd, published on 25 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-29069 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/snapcore/snapd (Go): affected all versions; no fix listed
- github.com/snapcore/snapd (Go): affected all versions; fixed in 2.62
- github.com/snapcore/snapd (Go): affected all versions; fixed in 2.62

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29069/ (Markdown: https://insights.sbomify.com/CVE-2024-29069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29069
- OSV: https://osv.dev/vulnerability/CVE-2024-29069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29069/
Summaries are generated and may contain mistakes; the official description above is the record.
