{"answers":{"affected":"3 open source packages ship an affected version, including anki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29073 exists.","fix":"Upgrade anki to 24.6 or later.","what":"CVE-2024-29073 is a medium-severity path traversal vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-29073 and fix it if it is affected.\n\nWhat it is: CVE-2024-29073 is a medium-severity path traversal vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29073 exists.\n\nAffected packages and fixed versions:\n- anki (PyPI): affected all versions; fixed in 24.6\n- anki (PyPI): affected all versions; fixed in 24.6\n- anki (PyPI): affected all versions; fixed in 24.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29073/ (Markdown: https://insights.sbomify.com/CVE-2024-29073/index.md)","id":"CVE-2024-29073","markdown":"https://insights.sbomify.com/CVE-2024-29073/index.md","name":"CVE-2024-29073","record":{"aliases":["DEBIAN-CVE-2024-29073","GHSA-x3r6-ccvq-cf5v","PYSEC-2026-1118","UBUNTU-CVE-2024-29073"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Anki flashcard app","requires_auth":"none","summary":"An attacker can read arbitrary files by sharing a specially crafted flashcard due to insufficient sanitization of LaTeX verbatim commands.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"anki","vendor":"ankiweb"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"An vulnerability in the handling of Latex exists in Ankitects Anki 24.04. When Latex is sanitized to prevent unsafe commands, the verbatim package, which comes installed by default in many Latex distributions, has been overlooked. A specially crafted flashcard can lead to an arbitrary file read. An attacker can share a flashcard to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Anki Latex Incomplete Blocklist Vulnerability","id":"CVE-2024-29073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Telephony has an improper input validation vulnerability","id":"CVE-2024-29074"},"packages":[{"ecosystem":"PyPI","fixed":["24.6"],"introduced":["0"],"last_affected":[],"package":"anki","purl":null,"source":"GHSA-x3r6-ccvq-cf5v"},{"ecosystem":"PyPI","fixed":["24.6"],"introduced":["0"],"last_affected":[],"package":"anki","purl":"pkg:pypi/anki","source":"GHSA-x3r6-ccvq-cf5v"},{"ecosystem":"PyPI","fixed":["24.6"],"introduced":["0"],"last_affected":[],"package":"anki","purl":"pkg:pypi/anki","source":"PYSEC-2026-1118"}],"prev":{"headline":"Privilege escalation in Foxit Reader","id":"CVE-2024-29072"},"products":["Anki"],"published":"2024-07-22","related":[{"cvss_score":9.6,"headline":"Ankitects Anki arbitrary script execution vulnerability","id":"CVE-2024-26020","kev_date_added":null,"published":"2024-07-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Ankitects"]},"summary":"An attacker can read arbitrary files by sharing a specially crafted flashcard due to insufficient sanitization of LaTeX verbatim commands.","url":"https://insights.sbomify.com/CVE-2024-29073/"}