# CVE-2024-2912: Insecure Deserialization Leading to RCE in bentoml/bentoml

> Attackers can execute arbitrary code on servers running BentoML by sending crafted serialized objects to valid endpoints.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-hvj5-mvw9-93j3, PYSEC-2026-296

## What is CVE-2024-2912?

CVE-2024-2912 is a critical unsafe deserialization vulnerability in bentoml/bentoml, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An insecure deserialization vulnerability exists in the BentoML framework, allowing remote code execution (RCE) by sending a specially crafted POST request. By exploiting this vulnerability, attackers can execute arbitrary commands on the server hosting the BentoML application. The vulnerability is triggered when a serialized object, crafted to execute OS commands upon deserialization, is sent to any valid BentoML endpoint. This issue poses a significant security risk, enabling attackers to compromise the server and potentially gain unauthorized access or control.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2024-2912?

3 open source packages ship an affected version, including bentoml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bentoml` | PyPI | All versions | 1.2.5 |
| `bentoml` | PyPI | All versions | 1.2.5 |
| `bentoml` | PyPI | All versions | 1.2.5 |

## How do I fix CVE-2024-2912?

Upgrade bentoml to 1.2.5 or later.

## Is CVE-2024-2912 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2912 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2912 and fix it if it is affected.

What it is: CVE-2024-2912 is a critical unsafe deserialization vulnerability in bentoml/bentoml, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2912 exists.

Affected packages and fixed versions:
- bentoml (PyPI): affected all versions; fixed in 1.2.5
- bentoml (PyPI): affected all versions; fixed in 1.2.5
- bentoml (PyPI): affected all versions; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2912/ (Markdown: https://insights.sbomify.com/CVE-2024-2912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2912
- OSV: https://osv.dev/vulnerability/CVE-2024-2912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2912/
Summaries are generated and may contain mistakes; the official description above is the record.
