{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 4 products.","exploited":"There is no known exploitation of CVE-2024-29131 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-configuration2 to 2.10.1 or later.","what":"CVE-2024-29131 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29131 and fix it if it is affected.\n\nWhat it is: CVE-2024-29131 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29131 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-configuration2 (Maven): affected from 2.0; fixed in 2.10.1\n- org.apache.commons:commons-configuration2 (Maven): affected from 2.0; fixed in 2.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29131/ (Markdown: https://insights.sbomify.com/CVE-2024-29131/index.md)","id":"CVE-2024-29131","markdown":"https://insights.sbomify.com/CVE-2024-29131/index.md","name":"CVE-2024-29131","record":{"aliases":["CLEANSTART-2026-OO91322","CLEANSTART-2026-PK50112","CLSA-2026-1789201689","CLSA-2026-1792011149","CLSA-2026-1793128350","DEBIAN-CVE-2024-29131","ECHO-17b6-9d89-71db","GHSA-xjp4-hw94-mvp5","MINI-98pv-63q9-7wmf","MINI-c9p3-27r3-hgwc","MINI-pw4w-v6vw-w5wx","MINI-w7xx-6wx9-5m9m","UBUNTU-CVE-2024-29131"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java configuration library","requires_auth":"none","summary":"An attacker can cause a StackOverflowError in Apache Commons Configuration by adding a specific property, leading to application crash.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"commons_configuration","vendor":"apache"},{"product":"fedora","vendor":"fedoraproject"},{"product":"ontap_tools","vendor":"netapp"},{"product":"snapcenter","vendor":"netapp"}],"cvss":{"score":7.3,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.\n\nUsers are recommended to upgrade to version 2.10.1, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()","id":"CVE-2024-29131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"fedoraproject:fedora","products":["fedoraproject:fedora","netapp:snapcenter"],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree","id":"CVE-2024-29133"},"packages":[{"ecosystem":"Maven","fixed":["2.10.1"],"introduced":["2.0"],"last_affected":[],"package":"org.apache.commons:commons-configuration2","purl":null,"source":"GHSA-xjp4-hw94-mvp5"},{"ecosystem":"Maven","fixed":["2.10.1"],"introduced":["2.0"],"last_affected":[],"package":"org.apache.commons:commons-configuration2","purl":"pkg:maven/org.apache.commons/commons-configuration2","source":"GHSA-xjp4-hw94-mvp5"}],"prev":{"headline":"WordPress Contact Form 7 – PayPal \u0026 Stripe Add-on plugin \u003c= 2.0 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-29130"},"products":["Apache Commons Configuration"],"published":"2024-03-21","related":[{"cvss_score":10,"headline":"Remote code execution in Apache Commons Configuration","id":"CVE-2020-1953","kev_date_added":null,"published":"2020-03-13"},{"cvss_score":9.8,"headline":"Apache Commons Configuration insecure interpolation defaults","id":"CVE-2022-33980","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":6.5,"headline":"Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x","id":"CVE-2025-46392","kev_date_added":null,"published":"2025-05-09"},{"cvss_score":5.4,"headline":"Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree","id":"CVE-2024-29133","kev_date_added":null,"published":"2024-03-21"},{"cvss_score":5.3,"headline":"Apache Commons Configuration: StackOverflowError for YAML input with cycles","id":"CVE-2026-45205","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"An attacker can cause a StackOverflowError in Apache Commons Configuration by adding a specific property, leading to application crash.","url":"https://insights.sbomify.com/CVE-2024-29131/"}