# CVE-2024-29131: Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()

> An attacker can cause a StackOverflowError in Apache Commons Configuration by adding a specific property, leading to application crash.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** CLEANSTART-2026-OO91322, CLEANSTART-2026-PK50112, CLSA-2026-1789201689, CLSA-2026-1792011149, CLSA-2026-1793128350, DEBIAN-CVE-2024-29131, ECHO-17b6-9d89-71db, GHSA-xjp4-hw94-mvp5, MINI-98pv-63q9-7wmf, MINI-c9p3-27r3-hgwc, MINI-pw4w-v6vw-w5wx, MINI-w7xx-6wx9-5m9m, UBUNTU-CVE-2024-29131

## What is CVE-2024-29131?

CVE-2024-29131 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.

Users are recommended to upgrade to version 2.10.1, which fixes the issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2024-29131?

2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-configuration2` | Maven | From 2.0 | 2.10.1 |
| `org.apache.commons:commons-configuration2` | Maven | From 2.0 | 2.10.1 |

Products: Apache Commons Configuration, Fedoraproject Fedora, Netapp Ontap Tools, Netapp Snapcenter.

## How do I fix CVE-2024-29131?

Upgrade org.apache.commons:commons-configuration2 to 2.10.1 or later.

## Is CVE-2024-29131 being exploited?

There is no known exploitation of CVE-2024-29131 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2020-1953](https://insights.sbomify.com/CVE-2020-1953/): Remote code execution in Apache Commons Configuration (critical 10.0)
- [CVE-2022-33980](https://insights.sbomify.com/CVE-2022-33980/): Apache Commons Configuration insecure interpolation defaults (critical 9.8)
- [CVE-2025-46392](https://insights.sbomify.com/CVE-2025-46392/): Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x (medium 6.5)
- [CVE-2024-29133](https://insights.sbomify.com/CVE-2024-29133/): Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree (medium 5.4)
- [CVE-2026-45205](https://insights.sbomify.com/CVE-2026-45205/): Apache Commons Configuration: StackOverflowError for YAML input with cycles (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29131 and fix it if it is affected.

What it is: CVE-2024-29131 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29131 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-configuration2 (Maven): affected from 2.0; fixed in 2.10.1
- org.apache.commons:commons-configuration2 (Maven): affected from 2.0; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29131/ (Markdown: https://insights.sbomify.com/CVE-2024-29131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29131
- OSV: https://osv.dev/vulnerability/CVE-2024-29131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29131/
Summaries are generated and may contain mistakes; the official description above is the record.
