CVE-2024-29133 Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree

Medium 5.4 Published Updated

Attackers can cause a StackOverflowError and denial of service by providing a cyclical object tree to the ListDelimiterHandler.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29133?

CVE-2024-29133 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.

Users are recommended to upgrade to version 2.10.1, which fixes the issue.

Weakness: CWE-787

Which versions are affected by CVE-2024-29133?

2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 2 products.

PackageAffectedFixed in
org.apache.commons:commons-configuration2 MavenFrom 2.02.10.1
org.apache.commons:commons-configuration2 MavenFrom 2.02.10.1

Products include Apache Commons Configuration, Fedoraproject Fedora.

How do I fix CVE-2024-29133?

Upgrade org.apache.commons:commons-configuration2 to 2.10.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-29133 being exploited?

There is no known exploitation of CVE-2024-29133 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as CLEANSTART-2026-GS71928, CLEANSTART-2026-ZE83350, DEBIAN-CVE-2024-29133, ECHO-7552-971a-4bb6, GHSA-9w38-p64v-xpmv, MINI-cq76-mphj-336c and 4 more.

Is CVE-2024-29133 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free