{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.commons:commons-configuration2. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-29133 in the wild and no public exploit code.","fix":"Upgrade org.apache.commons:commons-configuration2 to 2.10.1 or later.","what":"CVE-2024-29133 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29133 and fix it if it is affected.\n\nWhat it is: CVE-2024-29133 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 21 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29133 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.commons:commons-configuration2 (Maven): affected from 2.0; fixed in 2.10.1\n- org.apache.commons:commons-configuration2 (Maven): affected from 2.0; fixed in 2.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29133/ (Markdown: https://insights.sbomify.com/CVE-2024-29133/index.md)","id":"CVE-2024-29133","markdown":"https://insights.sbomify.com/CVE-2024-29133/index.md","name":"CVE-2024-29133","record":{"aliases":["CLEANSTART-2026-GS71928","CLEANSTART-2026-ZE83350","DEBIAN-CVE-2024-29133","ECHO-7552-971a-4bb6","GHSA-9w38-p64v-xpmv","MINI-cq76-mphj-336c","MINI-f245-9j9j-w2pp","MINI-fh8x-q6xq-vwpj","MINI-xh9m-gqh3-fgrp","UBUNTU-CVE-2024-29133"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java configuration library","requires_auth":"low_privilege","summary":"Attackers can cause a StackOverflowError and denial of service by providing a cyclical object tree to the ListDelimiterHandler.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"commons_configuration","vendor":"apache"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1.\n\nUsers are recommended to upgrade to version 2.10.1, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Commons Configuration: StackOverflowError calling ListDelimiterHandler.flatten(Object, int) with a cyclical object tree","id":"CVE-2024-29133","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"WordPress Tourfic plugin \u003c= 2.11.8 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-29134"},"packages":[{"ecosystem":"Maven","fixed":["2.10.1"],"introduced":["2.0"],"last_affected":[],"package":"org.apache.commons:commons-configuration2","purl":null,"source":"GHSA-9w38-p64v-xpmv"},{"ecosystem":"Maven","fixed":["2.10.1"],"introduced":["2.0"],"last_affected":[],"package":"org.apache.commons:commons-configuration2","purl":"pkg:maven/org.apache.commons/commons-configuration2","source":"GHSA-9w38-p64v-xpmv"}],"prev":{"headline":"Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()","id":"CVE-2024-29131"},"products":["Apache Commons Configuration"],"published":"2024-03-21","related":[{"cvss_score":10,"headline":"Remote code execution in Apache Commons Configuration","id":"CVE-2020-1953","kev_date_added":null,"published":"2020-03-13"},{"cvss_score":9.8,"headline":"Apache Commons Configuration insecure interpolation defaults","id":"CVE-2022-33980","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":7.3,"headline":"Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()","id":"CVE-2024-29131","kev_date_added":null,"published":"2024-03-21"},{"cvss_score":6.5,"headline":"Apache Commons Configuration: Uncontrolled Resource Consumption when loading untrusted configurations in 1.x","id":"CVE-2025-46392","kev_date_added":null,"published":"2025-05-09"},{"cvss_score":5.3,"headline":"Apache Commons Configuration: StackOverflowError for YAML input with cycles","id":"CVE-2026-45205","kev_date_added":null,"published":"2026-05-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause a StackOverflowError and denial of service by providing a cyclical object tree to the ListDelimiterHandler.","url":"https://insights.sbomify.com/CVE-2024-29133/"}