# CVE-2024-29156: Information leakage in YAQL

> Attackers can leak sensitive service account information due to insufficient sanitization in the YAQL language extension used by OpenStack Murano.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2024
- **Updated:** 25 Mar 2025
- **Also known as:** DEBIAN-CVE-2024-29156, GHSA-mvf6-hwxh-7v76, OESA-2024-1328, OESA-2024-1329, OESA-2024-1330, OESA-2024-1331, OESA-2024-1332, PYSEC-2026-2059, RHSA-2024:1930, RHSA-2024:1931, RHSA-2024:4053, UBUNTU-CVE-2024-29156

## What is CVE-2024-29156?

CVE-2024-29156 is a medium-severity vulnerability in n/a, published on 18 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In OpenStack Murano through 16.0.0, when YAQL before 3.0.0 is used, the Murano service's MuranoPL extension to the YAQL language fails to sanitize the supplied environment, leading to potential leakage of sensitive service account information.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-29156?

3 open source packages ship an affected version, including yaql. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yaql` | PyPI | All versions | 3.0.0 |
| `yaql` | PyPI | All versions | 3.0.0 |
| `yaql` | PyPI | All versions | 3.0.0 |
| `openstack-tripleo-common` | Red Hat:openstack:16.2::el8 | All versions | 0:11.7.1-2.20230809225405.e189622.el8ost |
| `openstack-tripleo-common-container-base` | Red Hat:openstack:16.2::el8 | All versions | 0:11.7.1-2.20230809225405.e189622.el8ost |
| `openstack-tripleo-common-containers` | Red Hat:openstack:16.2::el8 | All versions | 0:11.7.1-2.20230809225405.e189622.el8ost |
| `openstack-tripleo-common-devtools` | Red Hat:openstack:16.2::el8 | All versions | 0:11.7.1-2.20230809225405.e189622.el8ost |
| `openstack-tripleo-heat-templates` | Red Hat:openstack:16.2::el8 | All versions | 0:11.6.1-2.20230808225220.el8ost |
| `python-yaql` | Red Hat:openstack:16.2::el8 | All versions | 0:1.1.3-9.el8ost |
| `python3-tripleo-common` | Red Hat:openstack:16.2::el8 | All versions | 0:11.7.1-2.20230809225405.e189622.el8ost |
| `python3-yaql` | Red Hat:openstack:16.2::el8 | All versions | 0:1.1.3-9.el8ost |
| `openstack-tripleo-heat-templates` | Red Hat:openstack:17.1::el8 | All versions | 0:14.3.1-17.1.20231103003748.2.el8ost |
| `python-yaql` | Red Hat:openstack:17.1::el8 | All versions | 0:1.1.3-11.el8ost |
| `python3-yaql` | Red Hat:openstack:17.1::el8 | All versions | 0:1.1.3-11.el8ost |
| `openstack-tripleo-heat-templates` | Red Hat:openstack:17.1::el9 | All versions | 0:14.3.1-17.1.20231103010826.2.el9ost |
| `python-yaql` | Red Hat:openstack:17.1::el9 | All versions | 0:1.1.3-11.el9ost |
| `python3-yaql` | Red Hat:openstack:17.1::el9 | All versions | 0:1.1.3-11.el9ost |

Products: Openstack Murano, Openstack Yaql.

## How do I fix CVE-2024-29156?

Upgrade yaql to 3.0.0 or later.

## Is CVE-2024-29156 being exploited?

There is no known exploitation of CVE-2024-29156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29156 and fix it if it is affected.

What it is: CVE-2024-29156 is a medium-severity vulnerability in n/a, published on 18 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29156 in the wild and no public exploit code.

Affected packages and fixed versions:
- yaql (PyPI): affected all versions; fixed in 3.0.0
- yaql (PyPI): affected all versions; fixed in 3.0.0
- yaql (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29156/ (Markdown: https://insights.sbomify.com/CVE-2024-29156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29156
- OSV: https://osv.dev/vulnerability/CVE-2024-29156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29156/
Summaries are generated and may contain mistakes; the official description above is the record.
