{"answers":{"affected":"2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-29179 in the wild and no public exploit code.","fix":"Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.","what":"CVE-2024-29179 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-29179 and fix it if it is affected.\n\nWhat it is: CVE-2024-29179 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-29179 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29179/ (Markdown: https://insights.sbomify.com/CVE-2024-29179/index.md)","id":"CVE-2024-29179","markdown":"https://insights.sbomify.com/CVE-2024-29179/index.md","name":"CVE-2024-29179","record":{"aliases":["GHSA-hm8r-95g3-5hj9"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"high_privilege","summary":"An admin can upload malicious attachments that execute JavaScript in other users' browsers, enabling cross-site scripting attacks.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. An attacker with admin privileges can upload an attachment containing JS code without extension and the application will render it as HTML which allows for XSS attacks.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyFAQ Stored Cross-site Scripting at File Attachments","id":"CVE-2024-29179","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"webpack-dev-middleware Path Traversal vulnerability","id":"CVE-2024-29180"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-hm8r-95g3-5hj9"},{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-hm8r-95g3-5hj9"}],"prev":{"headline":"Apache StreamPark: FreeMarker SSTI RCE Vulnerability","id":"CVE-2024-29178"},"products":["phpMyFAQ"],"published":"2024-03-25","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["thorsten"]},"summary":"An admin can upload malicious attachments that execute JavaScript in other users' browsers, enabling cross-site scripting attacks.","url":"https://insights.sbomify.com/CVE-2024-29179/"}