# CVE-2024-29179: phpMyFAQ Stored Cross-site Scripting at File Attachments

> An admin can upload malicious attachments that execute JavaScript in other users' browsers, enabling cross-site scripting attacks.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Mar 2024
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-hm8r-95g3-5hj9

## What is CVE-2024-29179?

CVE-2024-29179 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. An attacker with admin privileges can upload an attachment containing JS code without extension and the application will render it as HTML which allows for XSS attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-29179?

2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyfaq/phpmyfaq` | Packagist | From 3.2.5 | 3.2.6 |
| `phpmyfaq/phpmyfaq` | Packagist | From 3.2.5 | 3.2.6 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2024-29179?

Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.

## Is CVE-2024-29179 being exploited?

There is no known exploitation of CVE-2024-29179 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29179 and fix it if it is affected.

What it is: CVE-2024-29179 is a medium-severity cross-site scripting vulnerability in Phpmyfaq Phpmyfaq, published on 25 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-29179 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6
- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29179/ (Markdown: https://insights.sbomify.com/CVE-2024-29179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29179
- OSV: https://osv.dev/vulnerability/CVE-2024-29179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29179/
Summaries are generated and may contain mistakes; the official description above is the record.
