CVE-2024-29180 webpack-dev-middleware Path Traversal vulnerability
Attackers can read arbitrary files on developer machines via path traversal in webpack-dev-middleware due to insufficient URL validation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-29180?
CVE-2024-29180 is a high-severity path traversal vulnerability in webpack-dev-middleware, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Prior to versions 7.1.0, 6.1.2, and 5.3.4, the webpack-dev-middleware development middleware for devpack does not validate the supplied URL address sufficiently before returning the local file. It is possible to access any file on the developer's machine. The middleware can either work with the physical filesystem when reading the files or it can use a virtualized in-memory `memfs` filesystem. If `writeToDisk` configuration option is set to `true`, the physical filesystem is used. The `getFilenameFromUrl` method is used to parse URL and build the local file path. The public path prefix is stripped from the URL, and the `unsecaped` path suffix is appended to the `outputPath`. As the URL is not unescaped and normalized automatically before calling the midlleware, it is possible to use `%2e` and `%2f` sequences to perform path traversal attack.
Developers using `webpack-dev-server` or `webpack-dev-middleware` are affected by the issue. When the project is started, an attacker might access any file on the developer's machine and exfiltrate the content. If the development server is listening on a public IP address (or `0.0.0.0`), an attacker on the local network can access the local files without any interaction from the victim (direct connection to the port). If the server allows access from third-party domains, an attacker can send a malicious link to the victim. When visited, the client side script can connect to the local server and exfiltrate the local files. Starting with fixed versions 7.1.0, 6.1.2, and 5.3.4, the URL is unescaped and normalized before any further processing.
Weakness: CWE-22
Which versions are affected by CVE-2024-29180?
6 open source packages ship an affected version, including webpack-dev-middleware. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
webpack-dev-middleware npm | All versions | 5.3.4 |
webpack-dev-middleware npm | All versions | 5.3.4 |
webpack-dev-middleware npm | From 6.0.0 | 6.1.2 |
webpack-dev-middleware npm | From 6.0.0 | 6.1.2 |
webpack-dev-middleware npm | From 7.0.0 | 7.1.0 |
webpack-dev-middleware npm | From 7.0.0 | 7.1.0 |
Products include Webpack.js Webpack-Dev-Middleware.
How do I fix CVE-2024-29180?
Upgrade webpack-dev-middleware to a fixed version for your release line: 5.3.4, 6.1.2 or 7.1.0.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-29180 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29180 exists.
Sources
Also known as CLSA-2026-1774311626, CLSA-2026-1774311628, CLSA-2026-1774311629, CLSA-2026-1774311637, CLSA-2026-1776299675, CLSA-2026-1776299676 and 10 more.