# CVE-2024-29181: @strapi/plugin-content-manager leaks data via relations via the Admin Panel

> An Author role user can view associated items in collections they did not create, leading to unauthorized data disclosure.

- **Severity:** Low 2.3 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6j89-frxc-q26m

## What is CVE-2024-29181?

CVE-2024-29181 is a low-severity missing authorization vulnerability in strapi, published on 12 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Strapi is an open-source content management system. Prior to version 4.19.1, a super admin can create a collection where an item in the collection has an association to another collection. When this happens, another user with Author Role can see the list of associated items they did not create. They should see nothing but their own items they created not all items ever created. Users should upgrade @strapi/plugin-content-manager to version 4.19.1 to receive a patch.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-29181?

2 open source packages ship an affected version, including @strapi/plugin-content-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-content-manager` | npm | All versions | 4.19.1 |
| `@strapi/plugin-content-manager` | npm | All versions | 4.19.1 |

Products: Strapi Strapi.

## How do I fix CVE-2024-29181?

Upgrade @strapi/plugin-content-manager to 4.19.1 or later.

## Is CVE-2024-29181 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29181 exists.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29181 and fix it if it is affected.

What it is: CVE-2024-29181 is a low-severity missing authorization vulnerability in strapi, published on 12 Jun 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29181 exists.

Affected packages and fixed versions:
- @strapi/plugin-content-manager (npm): affected all versions; fixed in 4.19.1
- @strapi/plugin-content-manager (npm): affected all versions; fixed in 4.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29181/ (Markdown: https://insights.sbomify.com/CVE-2024-29181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29181
- OSV: https://osv.dev/vulnerability/CVE-2024-29181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29181/
Summaries are generated and may contain mistakes; the official description above is the record.
