# CVE-2024-29190: MobSF SSRF Vulnerability on assetlinks_check(act_name, well_knowns)

> An attacker can exploit missing input validation in MobSF to perform server-side request forgery, accessing internal services within the organization's infrastructure.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Mar 2024
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-wfgj-wrgh-h3r3, PYSEC-2024-257, PYSEC-2026-1677

## What is CVE-2024-29190?

CVE-2024-29190 is a high-severity server-side request forgery vulnerability in Mobile-Security-Framework-MobSF, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mobile Security Framework (MobSF) is a pen-testing, malware analysis and security assessment framework capable of performing static and dynamic analysis. In version 3.9.5 Beta and prior, MobSF does not perform any input validation when extracting the hostnames in `android:host`, so requests can also be sent to local hostnames. This can lead to server-side request forgery. An attacker can cause the server to make a connection to internal-only services within the organization's infrastructure. Commit 5a8eeee73c5f504a6c3abdf2a139a13804efdb77 has a hotfix for this issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-29190?

4 open source packages ship an affected version, including mobsfscan and mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsfscan` | PyPI | All versions | 0.3.8 |
| `mobsfscan` | PyPI | All versions | 0.3.8 |
| `mobsfscan` | PyPI | All versions | 0.3.8 |
| `mobsf` | PyPI | All versions | 3.9.7 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2024-29190?

Upgrade mobsfscan to 0.3.8 or later.

## Is CVE-2024-29190 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29190 exists.

## Other vulnerabilities in Mobile-Security-Framework-MobSF

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29190 and fix it if it is affected.

What it is: CVE-2024-29190 is a high-severity server-side request forgery vulnerability in Mobile-Security-Framework-MobSF, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29190 exists.

Affected packages and fixed versions:
- mobsfscan (PyPI): affected all versions; fixed in 0.3.8
- mobsfscan (PyPI): affected all versions; fixed in 0.3.8
- mobsfscan (PyPI): affected all versions; fixed in 0.3.8
- mobsf (PyPI): affected all versions; fixed in 3.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29190/ (Markdown: https://insights.sbomify.com/CVE-2024-29190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29190
- OSV: https://osv.dev/vulnerability/CVE-2024-29190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29190/
Summaries are generated and may contain mistakes; the official description above is the record.
