CVE-2024-29192 GHSL-2023-206 gotortc Cross-Site Request Forgery vulnerability

High 8.8 Published Updated

Cross-site request forgery in go2rtc allows attackers to modify configuration and execute arbitrary commands via the exec handler if the victim visits a malicious site.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-29192?

CVE-2024-29192 is a high-severity vulnerability in AlexxIT go2rtc, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

gotortc is a camera streaming application. Versions 1.8.5 and prior are vulnerable to Cross-Site Request Forgery. The `/api/config` endpoint allows one to modify the existing configuration with user-supplied values. While the API is only allowing localhost to interact without authentication, an attacker may be able to achieve that depending on how go2rtc is set up on the upstream application, and given that this endpoint is not protected against CSRF, it allows requests from any origin (e.g. a "drive-by" attack) . The `exec` handler allows for any stream to execute arbitrary commands. An attacker may add a custom stream through `api/config`, which may lead to arbitrary command execution. In the event of a victim visiting the server in question, their browser will execute the requests against the go2rtc instance. Commit 8793c3636493c5efdda08f3b5ed5c6e1ea594fd9 adds a warning about secure API access.

Weakness: CWE-352

Which versions are affected by CVE-2024-29192?

3 open source packages ship an affected version, including github.com/AlexxIT/go2rtc. It affects 1 product.

PackageAffectedFixed in
github.com/AlexxIT/go2rtc GoAll versions1.9.0
github.com/AlexxIT/go2rtc GoAll versions1.9.0
github.com/AlexxIT/go2rtc GoAll versions1.9.0

Products include Alexxit Go2rtc.

How do I fix CVE-2024-29192?

Upgrade github.com/AlexxIT/go2rtc to 1.9.0 or later.

Is CVE-2024-29192 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29192 exists.

Sources

Also known as GHSA-qgj8-g9q4-7f2p, GO-2024-3052.

Is CVE-2024-29192 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free